summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-04-09 20:10:18 +0300
committerDimitris Kiziridis2020-04-09 20:10:18 +0300
commit27c2449e90bf49c92f05afe451c421eb780e0ff2 (patch)
tree1fa4ae0caaecbe1e604f60f1118b6d8ad4c7752d
parente80bea9ab13dbccc85eee717f69d2925fbc50f9c (diff)
downloadaur-27c2449e90bf49c92f05afe451c421eb780e0ff2.tar.gz
Update to 6.2.1
-rw-r--r--.SRCINFO31
-rw-r--r--MANIFEST.in24
-rw-r--r--PKGBUILD79
-rw-r--r--leo.desktop8
4 files changed, 50 insertions, 92 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f9acd0983f9e..66fad8e3ba44 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,36 +1,35 @@
pkgbase = leo
- pkgdesc = Literate programmer's editor, outliner, and project manager
- pkgver = 6.1
+ pkgdesc = Leo is an Outliner, Editor, and Personal Information Manager written in 100% Python
+ pkgver = 6.2.1
pkgrel = 1
url = http://leoeditor.com/
arch = any
- license = custom
+ license = MIT
+ license = Modified BSD
+ makedepends = python-setuptools
+ makedepends = gendesk
depends = python
- depends = python-setuptools
depends = desktop-file-utils
depends = shared-mime-info
depends = python-pyqt5
+ depends = python-pyqtwebengine
depends = python-docutils
depends = python-flexx
depends = python-meta
depends = jupyter-nbformat
depends = python-pylint
depends = python-pyflakes
- depends = python-shortcutter
+ depends = python-pyshortcuts
depends = python-sphinx
- depends = python-future
- depends = python-six
+ depends = python-black
+ depends = python-asttokens
optdepends = python-pyenchant: spellchecking support
- source = leo-6.1.tar.gz::https://github.com/leo-editor/leo-editor/archive/v6.1.tar.gz
- source = leo.desktop
- source = leo.xml
+ source = https://github.com/leo-editor/leo-editor/archive/v6.2.1.tar.gz
source = setup.py.patch
- source = MANIFEST.in
- sha256sums = dc08f8e765b9ac990afb485466493de3e00f607cb2ec149cf925532f3811f994
- sha256sums = 7b326791378eefedecee2474c4e1a497838d2a06ff4259a195d817c38588395b
- sha256sums = 630852279324b0d9acf656c4684f16777d64f49b4062bd101c5cddbfc33c82cb
- sha256sums = 20c22bd8a2e892c484d90c7643ab820454f9e6d892fa48a6075395ec2e2ebcc9
- sha256sums = 03ef3e169f8761c1b1624f2e49058005b0fc94a1591d201436221df119c8d41e
+ source = leo.xml
+ md5sums = 3e5fd517686cf52214ff70265fd00019
+ md5sums = SKIP
+ md5sums = SKIP
pkgname = leo
diff --git a/MANIFEST.in b/MANIFEST.in
deleted file mode 100644
index e111fc82249c..000000000000
--- a/MANIFEST.in
+++ /dev/null
@@ -1,24 +0,0 @@
-# Processed in order listed
-# Global
-#recursive-include leo *.* # not needed when using `graft`
-graft leo
-global-exclude *.py[cod] __pycache__ *.so
-
-# Root folder
-include *.TXT
-include launchLeo.py
-include profileLeo.py
-include pylint-leo.bat
-include pylint-leo.py
-include *.nsi
-# obscure pip bugfix https://github.com/pypa/setuptools/issues/1694
-include pyproject.toml
-
-# Exclusions
-# same as scrub_datafiles in setup.py, prior to Github commit 9982d17e2470ac8313050b8a0288cd39d7ad4f5b
-prune leo/test
-prune leo/doc/html
-
-# Issue #603, https://github.com/leo-editor/leo-editor/issues/603
-include leo/doc/html/conf.py
-include leo/doc/html/index.html
diff --git a/PKGBUILD b/PKGBUILD
index 30d237c4d6c5..958820a53c1f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,64 +1,55 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
# Contributor: Ronuk Raval <ronuk.raval at gmail dot com>
# Contributor: Narrat <autumn-wind at web dot de>
# Contributor: David Scholl <djscholl at gmail dot com>
pkgname=leo
-pkgver=6.1
+pkgver=6.2.1
pkgrel=1
-pkgdesc="Literate programmer's editor, outliner, and project manager"
+pkgdesc="Leo is an Outliner, Editor, and Personal Information Manager written in 100% Python"
arch=('any')
url="http://leoeditor.com/"
-license=('custom')
-depends=(
- python
- python-setuptools
- desktop-file-utils
- shared-mime-info
-
- python-pyqt5
- python-docutils
- python-flexx
- python-meta
- jupyter-nbformat
- python-pylint
- python-pyflakes
- python-shortcutter
- python-sphinx
- python-future
- python-six
-)
+license=('MIT' 'Modified BSD')
+depends=('python'
+ 'desktop-file-utils'
+ 'shared-mime-info'
+ 'python-pyqt5'
+ 'python-pyqtwebengine'
+ 'python-docutils'
+ 'python-flexx'
+ 'python-meta'
+ 'jupyter-nbformat'
+ 'python-pylint'
+ 'python-pyflakes'
+ 'python-pyshortcuts'
+ 'python-sphinx'
+ 'python-black'
+ 'python-asttokens')
+makedepends=('python-setuptools' 'gendesk')
optdepends=('python-pyenchant: spellchecking support')
-source=(
- ${pkgname}-${pkgver}.tar.gz::https://github.com/leo-editor/leo-editor/archive/v${pkgver}.tar.gz
- leo.desktop
- leo.xml
- setup.py.patch
- MANIFEST.in
-)
-sha256sums=('dc08f8e765b9ac990afb485466493de3e00f607cb2ec149cf925532f3811f994'
- '7b326791378eefedecee2474c4e1a497838d2a06ff4259a195d817c38588395b'
- '630852279324b0d9acf656c4684f16777d64f49b4062bd101c5cddbfc33c82cb'
- '20c22bd8a2e892c484d90c7643ab820454f9e6d892fa48a6075395ec2e2ebcc9'
- '03ef3e169f8761c1b1624f2e49058005b0fc94a1591d201436221df119c8d41e')
-
+source=("https://github.com/leo-editor/leo-editor/archive/v${pkgver}.tar.gz"
+ 'setup.py.patch'
+ 'leo.xml')
+md5sums=('3e5fd517686cf52214ff70265fd00019'
+ 'SKIP'
+ 'SKIP')
prepare() {
- cd "leo-editor-${pkgver}"
+ cd "${pkgname}-editor-${pkgver}"
patch -Np1 -i ../setup.py.patch
}
build() {
- cd "leo-editor-${pkgver}"
- cp ../MANIFEST.in ./
+ cd "${pkgname}-editor-${pkgver}"
python setup.py build
+ gendesk -f -n --pkgname "$pkgname" --pkgdesc "$pkgdesc" --mimetypes=application/x-leo-outline --exec="$pkgname" --categories=TextEditor\;Development --icon "$pkgname"
}
package() {
- cd "leo-editor-${pkgver}"
-
+ cd "${pkgname}-editor-${pkgver}"
python setup.py install --skip-build --root="$pkgdir/" --optimize=1
- install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -D -m644 "$srcdir/leo.desktop" "$pkgdir/usr/share/applications/leo.desktop"
- install -D -m644 "$srcdir/leo.xml" "$pkgdir/usr/share/mime/packages/leo.xml"
- install -D -m644 "leo/Icons/application-x-leo-outline.png" "$pkgdir/usr/share/pixmaps/leo.png"
-}
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 leo.desktop "${pkgdir}/usr/share/applications/leo.desktop"
+ install -Dm644 "$srcdir/leo.xml" "${pkgdir}/usr/share/mime/packages/leo.xml"
+ install -Dm644 "leo/Icons/application-x-leo-outline.png" "${pkgdir}/usr/share/pixmaps/leo.png"
+} \ No newline at end of file
diff --git a/leo.desktop b/leo.desktop
deleted file mode 100644
index ae401c013af4..000000000000
--- a/leo.desktop
+++ /dev/null
@@ -1,8 +0,0 @@
-[Desktop Entry]
-Name=Leo
-GenericName=Outliner
-Exec=leo
-Icon=leo
-MimeType=application/x-leo-outline;
-Type=Application
-Categories=Utility;TextEditor;