summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRonuk Raval2019-08-11 17:17:47 -0400
committerRonuk Raval2019-08-20 20:23:45 -0400
commit5da3e84618fd3ccc1a3f3f7d37894496e46a4424 (patch)
treebe26c9db2cb7d070b5ea03a594b4eb49a190f53b
parent18a2b784888e08370c0b518be9ed3b73a237563c (diff)
downloadaur-5da3e84618fd3ccc1a3f3f7d37894496e46a4424.tar.gz
v6.0
-rw-r--r--.SRCINFO12
-rw-r--r--MANIFEST.in24
-rw-r--r--PKGBUILD12
-rw-r--r--setup.py.patch19
4 files changed, 62 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c49e03c93112..89168a1f9333 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = leo
pkgdesc = Literate programmer's editor, outliner, and project manager
- pkgver = 5.9
+ pkgver = 6.0
pkgrel = 1
url = http://leoeditor.com/
arch = any
@@ -12,19 +12,25 @@ pkgbase = leo
depends = python-pyqt5
depends = python-docutils
depends = python-flexx
+ depends = python-meta
depends = jupyter-nbformat
depends = python-pylint
depends = python-pyflakes
+ depends = python-shortcutter
depends = python-sphinx
depends = python-future
depends = python-six
optdepends = python-pyenchant: spellchecking support
- source = leo-5.9.tar.gz::https://github.com/leo-editor/leo-editor/archive/v5.9.tar.gz
+ source = leo-6.0.tar.gz::https://github.com/leo-editor/leo-editor/archive/v6.0.tar.gz
source = leo.desktop
source = leo.xml
- sha256sums = 5636da46f167630c6515636c8057fb8dfa819351f3eac7d0d9137122a9234bd5
+ source = setup.py.patch
+ source = MANIFEST.in
+ sha256sums = 37a534cb5b567cf6cf6a816d9eb8f65aac201a166b050bbe04507182851e4a6c
sha256sums = 7b326791378eefedecee2474c4e1a497838d2a06ff4259a195d817c38588395b
sha256sums = 630852279324b0d9acf656c4684f16777d64f49b4062bd101c5cddbfc33c82cb
+ sha256sums = 6212a47d5e6b171dc3bcf845bcae007454145958eab6da441c0b2676e573724a
+ sha256sums = 03ef3e169f8761c1b1624f2e49058005b0fc94a1591d201436221df119c8d41e
pkgname = leo
diff --git a/MANIFEST.in b/MANIFEST.in
new file mode 100644
index 000000000000..e111fc82249c
--- /dev/null
+++ b/MANIFEST.in
@@ -0,0 +1,24 @@
+# Processed in order listed
+# Global
+#recursive-include leo *.* # not needed when using `graft`
+graft leo
+global-exclude *.py[cod] __pycache__ *.so
+
+# Root folder
+include *.TXT
+include launchLeo.py
+include profileLeo.py
+include pylint-leo.bat
+include pylint-leo.py
+include *.nsi
+# obscure pip bugfix https://github.com/pypa/setuptools/issues/1694
+include pyproject.toml
+
+# Exclusions
+# same as scrub_datafiles in setup.py, prior to Github commit 9982d17e2470ac8313050b8a0288cd39d7ad4f5b
+prune leo/test
+prune leo/doc/html
+
+# Issue #603, https://github.com/leo-editor/leo-editor/issues/603
+include leo/doc/html/conf.py
+include leo/doc/html/index.html
diff --git a/PKGBUILD b/PKGBUILD
index 5e89b2601589..5c95bcacbda1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: David Scholl <djscholl at gmail dot com>
pkgname=leo
-pkgver=5.9
+pkgver=6.0
pkgrel=1
pkgdesc="Literate programmer's editor, outliner, and project manager"
arch=('any')
@@ -18,9 +18,11 @@ depends=(
python-pyqt5
python-docutils
python-flexx
+ python-meta
jupyter-nbformat
python-pylint
python-pyflakes
+ python-shortcutter
python-sphinx
python-future
python-six
@@ -30,15 +32,21 @@ source=(
${pkgname}-${pkgver}.tar.gz::https://github.com/leo-editor/leo-editor/archive/v${pkgver}.tar.gz
leo.desktop
leo.xml
+ setup.py.patch
+ MANIFEST.in
)
sha256sums=(
- 5636da46f167630c6515636c8057fb8dfa819351f3eac7d0d9137122a9234bd5
+ 37a534cb5b567cf6cf6a816d9eb8f65aac201a166b050bbe04507182851e4a6c
7b326791378eefedecee2474c4e1a497838d2a06ff4259a195d817c38588395b
630852279324b0d9acf656c4684f16777d64f49b4062bd101c5cddbfc33c82cb
+ 6212a47d5e6b171dc3bcf845bcae007454145958eab6da441c0b2676e573724a
+ 03ef3e169f8761c1b1624f2e49058005b0fc94a1591d201436221df119c8d41e
)
build() {
cd "leo-editor-${pkgver}"
+ patch -i ../setup.py.patch
+ cp ../MANIFEST.in ./
python setup.py build
}
diff --git a/setup.py.patch b/setup.py.patch
new file mode 100644
index 000000000000..89580b7e60b4
--- /dev/null
+++ b/setup.py.patch
@@ -0,0 +1,19 @@
+--- setup.py 2019-08-11 16:34:25.584021489 -0400
++++ setup.py 2019-08-11 16:34:54.790714182 -0400
+@@ -117,7 +117,6 @@
+ 'meta', # for livecode.py plugin, which is enabled by default
+ 'nbformat', # for Jupyter notebook integration
+ 'pylint','pyflakes', # coding syntax standards
+- 'setupext-janitor >= 1.1', # extend `setup.py clean` #1055,#1255
+ 'shortcutter', # desktop integration (#1243)
+ 'sphinx', # rST plugin
+ 'future', # python 2/3 compatibility layer, same with 'six'
+@@ -169,7 +168,7 @@
+ setup_requires=setup_requires,
+ install_requires=user_requires,
+ entry_points=define_entry_points(),
+- cmdclass={'clean': janitor.CleanCommand} # clean more than setuptools, #1055
++ cmdclass=cmd_classes, # clean more than setuptools, #1055
+ )
+
+ #@@language python