summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-05-13 08:40:44 +0300
committerDimitris Kiziridis2020-05-13 08:40:44 +0300
commit78e4b8282fba3afb36429835a19eaf61c5bfb6f8 (patch)
tree7ba6b0339ae535b9d856dd45456dc00d1757517b
parent512420c453995df09ceee94eae62c55853cda907 (diff)
downloadaur-78e4b8282fba3afb36429835a19eaf61c5bfb6f8.tar.gz
sanitize pkgbuild
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6a254633af2f..924f9b93b758 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = leo
- pkgdesc = Leo is an Outliner, Editor, and Personal Information Manager written in 100% Python
+ pkgdesc = Outliner, Editor, and Personal Information Manager written in 100% Python
pkgver = 6.2.1
pkgrel = 1
- url = http://leoeditor.com/
+ url = http://leoeditor.com
arch = any
license = MIT
license = BSD
makedepends = python-setuptools
makedepends = gendesk
- depends = python
depends = desktop-file-utils
depends = shared-mime-info
depends = python-pyqt5
@@ -24,12 +23,12 @@ pkgbase = leo
depends = python-black
depends = python-asttokens
optdepends = python-pyenchant: spellchecking support
- source = https://github.com/leo-editor/leo-editor/archive/v6.2.1.tar.gz
+ source = leo-6.2.1.tar.gz::https://github.com/leo-editor/leo-editor/archive/v6.2.1.tar.gz
source = setup.py.patch
source = leo.xml
- md5sums = 3e5fd517686cf52214ff70265fd00019
- md5sums = SKIP
- md5sums = SKIP
+ sha256sums = 95ae6334e1c1ead096bae7695c1c0a0b8c6992a83ea6c88166f94dd750fc68ae
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = leo
diff --git a/PKGBUILD b/PKGBUILD
index 1abe7daa682a..ef1393aaac51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,12 +6,11 @@
pkgname=leo
pkgver=6.2.1
pkgrel=1
-pkgdesc="Leo is an Outliner, Editor, and Personal Information Manager written in 100% Python"
+pkgdesc="Outliner, Editor, and Personal Information Manager written in 100% Python"
arch=('any')
-url="http://leoeditor.com/"
+url="http://leoeditor.com"
license=('MIT' 'BSD')
-depends=('python'
- 'desktop-file-utils'
+depends=('desktop-file-utils'
'shared-mime-info'
'python-pyqt5'
'python-pyqtwebengine'
@@ -27,12 +26,12 @@ depends=('python'
'python-asttokens')
makedepends=('python-setuptools' 'gendesk')
optdepends=('python-pyenchant: spellchecking support')
-source=("https://github.com/leo-editor/leo-editor/archive/v${pkgver}.tar.gz"
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/leo-editor/leo-editor/archive/v${pkgver}.tar.gz"
'setup.py.patch'
'leo.xml')
-md5sums=('3e5fd517686cf52214ff70265fd00019'
- 'SKIP'
- 'SKIP')
+sha256sums=('95ae6334e1c1ead096bae7695c1c0a0b8c6992a83ea6c88166f94dd750fc68ae'
+ 'SKIP'
+ 'SKIP')
prepare() {
cd "${pkgname}-editor-${pkgver}"