summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2020-01-19 00:06:49 +0100
committerNarrat2020-01-19 00:07:13 +0100
commite80bea9ab13dbccc85eee717f69d2925fbc50f9c (patch)
tree798d9f6dbd63df43ef29ba6d3b0bfc7453f89088
parent5da3e84618fd3ccc1a3f3f7d37894496e46a4424 (diff)
downloadaur-e80bea9ab13dbccc85eee717f69d2925fbc50f9c.tar.gz
update to 6.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD23
-rw-r--r--setup.py.patch30
3 files changed, 32 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89168a1f9333..f9acd0983f9e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = leo
pkgdesc = Literate programmer's editor, outliner, and project manager
- pkgver = 6.0
+ pkgver = 6.1
pkgrel = 1
url = http://leoeditor.com/
arch = any
@@ -21,15 +21,15 @@ pkgbase = leo
depends = python-future
depends = python-six
optdepends = python-pyenchant: spellchecking support
- source = leo-6.0.tar.gz::https://github.com/leo-editor/leo-editor/archive/v6.0.tar.gz
+ source = leo-6.1.tar.gz::https://github.com/leo-editor/leo-editor/archive/v6.1.tar.gz
source = leo.desktop
source = leo.xml
source = setup.py.patch
source = MANIFEST.in
- sha256sums = 37a534cb5b567cf6cf6a816d9eb8f65aac201a166b050bbe04507182851e4a6c
+ sha256sums = dc08f8e765b9ac990afb485466493de3e00f607cb2ec149cf925532f3811f994
sha256sums = 7b326791378eefedecee2474c4e1a497838d2a06ff4259a195d817c38588395b
sha256sums = 630852279324b0d9acf656c4684f16777d64f49b4062bd101c5cddbfc33c82cb
- sha256sums = 6212a47d5e6b171dc3bcf845bcae007454145958eab6da441c0b2676e573724a
+ sha256sums = 20c22bd8a2e892c484d90c7643ab820454f9e6d892fa48a6075395ec2e2ebcc9
sha256sums = 03ef3e169f8761c1b1624f2e49058005b0fc94a1591d201436221df119c8d41e
pkgname = leo
diff --git a/PKGBUILD b/PKGBUILD
index 5c95bcacbda1..30d237c4d6c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer: Ronuk Raval <ronuk.raval at gmail dot com>
+# Contributor: Ronuk Raval <ronuk.raval at gmail dot com>
# Contributor: Narrat <autumn-wind at web dot de>
# Contributor: David Scholl <djscholl at gmail dot com>
pkgname=leo
-pkgver=6.0
+pkgver=6.1
pkgrel=1
pkgdesc="Literate programmer's editor, outliner, and project manager"
arch=('any')
@@ -35,17 +35,20 @@ source=(
setup.py.patch
MANIFEST.in
)
-sha256sums=(
- 37a534cb5b567cf6cf6a816d9eb8f65aac201a166b050bbe04507182851e4a6c
- 7b326791378eefedecee2474c4e1a497838d2a06ff4259a195d817c38588395b
- 630852279324b0d9acf656c4684f16777d64f49b4062bd101c5cddbfc33c82cb
- 6212a47d5e6b171dc3bcf845bcae007454145958eab6da441c0b2676e573724a
- 03ef3e169f8761c1b1624f2e49058005b0fc94a1591d201436221df119c8d41e
-)
+sha256sums=('dc08f8e765b9ac990afb485466493de3e00f607cb2ec149cf925532f3811f994'
+ '7b326791378eefedecee2474c4e1a497838d2a06ff4259a195d817c38588395b'
+ '630852279324b0d9acf656c4684f16777d64f49b4062bd101c5cddbfc33c82cb'
+ '20c22bd8a2e892c484d90c7643ab820454f9e6d892fa48a6075395ec2e2ebcc9'
+ '03ef3e169f8761c1b1624f2e49058005b0fc94a1591d201436221df119c8d41e')
+
+
+prepare() {
+ cd "leo-editor-${pkgver}"
+ patch -Np1 -i ../setup.py.patch
+}
build() {
cd "leo-editor-${pkgver}"
- patch -i ../setup.py.patch
cp ../MANIFEST.in ./
python setup.py build
}
diff --git a/setup.py.patch b/setup.py.patch
index 89580b7e60b4..816cbaf278e7 100644
--- a/setup.py.patch
+++ b/setup.py.patch
@@ -1,19 +1,19 @@
---- setup.py 2019-08-11 16:34:25.584021489 -0400
-+++ setup.py 2019-08-11 16:34:54.790714182 -0400
-@@ -117,7 +117,6 @@
- 'meta', # for livecode.py plugin, which is enabled by default
- 'nbformat', # for Jupyter notebook integration
- 'pylint','pyflakes', # coding syntax standards
-- 'setupext-janitor >= 1.1', # extend `setup.py clean` #1055,#1255
- 'shortcutter', # desktop integration (#1243)
- 'sphinx', # rST plugin
- 'future', # python 2/3 compatibility layer, same with 'six'
-@@ -169,7 +168,7 @@
+--- leo-editor-6.1/setup.py
++++ leo-editor-6.1/setup.py
+@@ -113,7 +113,6 @@
+ 'meta', # for livecode.py plugin, which is enabled by default
+ 'nbformat', # for Jupyter notebook integration
+ 'pylint', 'pyflakes', 'black', # coding syntax standards
+- 'setupext-janitor >= 1.1', # extend `setup.py clean` #1055,#1255
+ 'pyshortcuts >= 1.7', # desktop integration (#1243)
+ 'sphinx', # rST plugin
+ 'windows-curses; platform_system=="Windows"', # for console mode on Windows
+@@ -165,7 +164,7 @@
setup_requires=setup_requires,
install_requires=user_requires,
entry_points=define_entry_points(),
-- cmdclass={'clean': janitor.CleanCommand} # clean more than setuptools, #1055
-+ cmdclass=cmd_classes, # clean more than setuptools, #1055
+- cmdclass={'clean': janitor.CleanCommand}, # clean more than setuptools, #1055
++ cmdclass=cmd_classes, # clean more than setuptools, #1055
+ python_requires='>=3.6',
)
-
- #@@language python
+