summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSeth Schroeder2015-07-07 18:55:15 -0700
committerSeth Schroeder2015-07-07 18:55:15 -0700
commitd2d109348a1a467672439bc02b25782c2c0ab6fe (patch)
tree8ad4d065d6060967417db73d8cbb0ada38df2d28
downloadaur-d2d109348a1a467672439bc02b25782c2c0ab6fe.tar.gz
First commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD43
-rw-r--r--leocad.sh3
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..90d62a73a3a4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = leocad
+ pkgdesc = LeoCAD is a CAD program for creating virtual LEGO models. It has an easy to use interface and currently includes over 6000 different pieces created by the LDraw community.
+ pkgver = 0.82.1
+ pkgrel = 1
+ url = http://leocad.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = qtchooser
+ depends = zlib
+ depends = libjpeg
+ depends = libpng
+ depends = gtk2
+ depends = mesa
+ source = https://github.com/tozian/leocad-arch/raw/master/source/LeoCAD-Source-0.82.1.tgz
+ source = http://github.com/tozian/leocad-arch/raw/master/source/Library-Linux-8750.zip
+ source = leocad.sh
+ md5sums = 96e0cd9f36ca0e1370dcf470b1b96f1d
+ md5sums = fe83cd80b58a52c556f64801bc9f9302
+ md5sums = cbe0189f828a7cf6a42754352a72eeac
+
+pkgname = leocad
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..488ad09a727c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Contributor: Seth Schroeder <theking@kingdomofseth.com>
+# Contributor: Sven Schneider <archlinux.sandmann@googlemail.com>
+
+pkgname=leocad
+pkgver=0.82.1
+_piecesver=8750
+pkgrel=1
+pkgdesc="LeoCAD is a CAD program for creating virtual LEGO models. It
+has an easy to use interface and currently includes over 6000 different
+pieces created by the LDraw community."
+arch=('i686' 'x86_64')
+url="http://leocad.org"
+license=('GPL')
+makedepends=('qtchooser')
+depends=('zlib' 'libjpeg' 'libpng' 'gtk2' 'mesa')
+source=(https://github.com/tozian/leocad-arch/raw/master/source/LeoCAD-Source-${pkgver}.tgz
+http://github.com/tozian/leocad-arch/raw/master/source/Library-Linux-${_piecesver}.zip
+leocad.sh)
+md5sums=('96e0cd9f36ca0e1370dcf470b1b96f1d'
+'fe83cd80b58a52c556f64801bc9f9302'
+'cbe0189f828a7cf6a42754352a72eeac')
+
+build() {
+cd "${srcdir}/${pkgname}"
+
+# install the binary to /usr/share
+qmake-qt4 leocad.pro
+sed 's#$(INSTALL_ROOT)/usr/bin#$(INSTALL_ROOT)/usr/share/leocad/bin#g' -i Makefile
+make
+}
+
+package() {
+cd "${srcdir}/${pkgname}"
+
+make INSTALL_ROOT="${pkgdir}" install
+
+install -dm755 "${pkgdir}/usr/share/leocad/pieces/"
+install -Dm644 "${srcdir}/library.bin" "${pkgdir}/usr/share/leocad/pieces/library.bin"
+
+install -dm755 "${pkgdir}/usr/bin/"
+install -Dm755 "${srcdir}/leocad.sh" "${pkgdir}/usr/bin/leocad"
+}
+
diff --git a/leocad.sh b/leocad.sh
new file mode 100644
index 000000000000..9db087b212de
--- /dev/null
+++ b/leocad.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+/usr/share/leocad/bin/leocad -l /usr/share/leocad/pieces/library.bin
+