summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteffen Weber2016-07-14 23:04:44 +0200
committerSteffen Weber2016-07-14 23:04:44 +0200
commit038ca0caf3333faff7f4662ec05d374523ee3cb6 (patch)
treee7e04b10bd35b2477f5f40f8293332782f1d1079
downloadaur-038ca0caf3333faff7f4662ec05d374523ee3cb6.tar.gz
Initial release
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD34
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c61c1f72007c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Thu Jul 14 21:03:58 UTC 2016
+pkgbase = lepton
+ pkgdesc = Tool and file format for losslessly compressing JPEGs
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/dropbox/lepton
+ arch = i686
+ arch = x86_64
+ license = APACHE
+ makedepends = cmake
+ makedepends = git
+ makedepends = libvpx
+ source = lepton-1.0::https://github.com/dropbox/lepton/archive/1.0.tar.gz
+ source = lepton-correct-header.patch::https://github.com/dropbox/lepton/commit/5856187c0358411ae9fadc66a49de070382bf694.patch
+ md5sums = f16f95418689ca63bff936cb3140192c
+ md5sums = c0e463550a94ceb0f4621ce61da6f307
+
+pkgname = lepton
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8aac7c10667d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Steffen Weber <-boenki-gmx-de->
+
+pkgname=lepton
+pkgver=1.0
+pkgrel=1
+pkgdesc="Tool and file format for losslessly compressing JPEGs"
+arch=('i686' 'x86_64')
+url="https://github.com/dropbox/lepton"
+license=('APACHE')
+makedepends=('cmake' 'git' 'libvpx')
+#depends=()
+source=($pkgname-$pkgver::$url/archive/$pkgver.tar.gz
+ $pkgname-correct-header.patch::$url/commit/5856187c0358411ae9fadc66a49de070382bf694.patch)
+md5sums=('f16f95418689ca63bff936cb3140192c'
+ 'c0e463550a94ceb0f4621ce61da6f307')
+
+prepare() {
+ cd $pkgname-$pkgver
+ patch -p1 -i ../$pkgname-correct-header.patch
+}
+
+build() {
+ cd $pkgname-$pkgver
+ git init
+ cmake -DCMAKE_BUILD_TYPE=release
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ install -Dm755 lepton $pkgdir/usr/bin/lepton
+ install -Dm755 lepton-avx $pkgdir/usr/bin/lepton-avx
+ install -Dm755 test_invariants $pkgdir/usr/bin/test_invariants
+}