summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIan Glen2017-11-11 00:24:06 -0500
committerIan Glen2017-11-11 00:24:06 -0500
commite03367049505fa500fc4fcb89e353af7ad9283b0 (patch)
tree4ede1e50efaec4ba02a4de4e46607cddb649abf8
downloadaur-e03367049505fa500fc4fcb89e353af7ad9283b0.tar.gz
Created package
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD44
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4954acf3ce9d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = lepton-eda-git
+ pkgdesc = A full GPL'd suite and toolkit of Electronic Design Automation tools. Forked from gEDA in late 2016.
+ pkgver = 7748.d2550597b
+ pkgrel = 1
+ url = https://github.com/lepton-eda/lepton-eda
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = pkg-config
+ makedepends = flex
+ makedepends = gawk
+ depends = gtk2
+ depends = guile
+ depends = guile2.0
+ depends = libstroke
+ optdepends = python2: for two of the commands (garchive, tragesym)
+ optdepends = gawk: for sw2asc
+ provides = $_gitname
+ conflicts = $_gitname
+ conflicts = geda-gaf
+ source = git+https://github.com/lepton-eda/lepton-eda.git
+ md5sums = SKIP
+
+pkgname = lepton-eda-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f130b2153da7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Ian Glen <ian@ianglen.me>
+
+pkgname=lepton-eda-git
+_gitname=lepton-eda
+pkgver=7748.d2550597b
+pkgrel=1
+pkgdesc="A full GPL'd suite and toolkit of Electronic Design Automation tools. Forked from gEDA in late 2016."
+arch=('i686' 'x86_64')
+url="https://github.com/lepton-eda/lepton-eda"
+license=('GPL')
+depends=('gtk2' 'guile' 'guile2.0' 'libstroke')
+makedepends=('pkg-config' 'flex' 'gawk')
+optdepends=('python2: for two of the commands (garchive, tragesym)'
+ 'gawk: for sw2asc')
+provides=('$_gitname')
+conflicts=('$_gitname' 'geda-gaf')
+source=('git+https://github.com/lepton-eda/lepton-eda.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build ()
+{
+ cd "$srcdir/$_gitname"
+
+ ./autogen.sh
+ ./configure --prefix=/usr --disable-update-xdg-database
+ make
+}
+
+package ()
+{
+ cd "$srcdir/$_gitname"
+ make DESTDIR="$pkgdir/" install
+ sed -i 's+/usr/bin/env python+/usr/bin/env python2+' \
+ "$pkgdir/usr/bin/garchive"
+ sed -i 's+/usr/bin/python+/usr/bin/python2+' \
+ "$pkgdir/usr/bin/tragesym"
+ sed -i 's+/usr/bin/python+/usr/bin/python2+' \
+ "$pkgdir/usr/share/doc/$_gitname/examples/lightning_detector/bom"
+}