summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Radel2022-09-12 23:02:52 +0200
committerBenjamin Radel2022-09-12 23:02:52 +0200
commit002f6659698f3f40f1307f572818ee277640d38a (patch)
tree56eae06478733a6e1b902893a58afc4e5a45ddb9
downloadaur-002f6659698f3f40f1307f572818ee277640d38a.tar.gz
Initial Commit
Create leqm-nrt-git for DoM-git packages
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..257907b2ceb6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = leqm-nrt-git
+ pkgdesc = An open source implementation of Leq(M) measurement with patches from Carl
+ pkgver = 0.0.2.r10.gb795210
+ pkgrel = 1
+ url = https://git.carlh.net/gitweb/?p=leqm-nrt.git;a=summary
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = python
+ provides = leqm-nrt
+ conflicts = leqm-nrt
+ source = leqm-nrt-git::git+git://git.carlh.net/git/leqm-nrt.git#branch=carl
+ sha256sums = SKIP
+
+pkgname = leqm-nrt-git
+ pkgdesc = An open source implementation of Leq(M) measurement with patches from Carl
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fb3c178e2311
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Markus Kalb <mk@filmkreis.tu-darmstadt.de>
+# Maintainer: Benjamin Radel <aur@radel.tk>
+
+pkgname=leqm-nrt-git
+pkgver=0.0.2.r10.gb795210
+_branch=carl
+pkgrel=1
+pkgdesc="An open source implementation of Leq(M) measurement with patches from Carl"
+arch=('x86_64')
+url="https://git.carlh.net/gitweb/?p=leqm-nrt.git;a=summary"
+license=(GPL2)
+makedepends=(git python)
+source=(
+ "$pkgname::git+git://git.carlh.net/git/leqm-nrt.git#branch=${_branch}"
+)
+sha256sums=('SKIP')
+conflicts=('leqm-nrt')
+provides=('leqm-nrt')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$pkgname"
+ ./waf configure --without-libsndfile --prefix=/usr
+ ./waf build
+}
+
+package() {
+ pkgdesc="An open source implementation of Leq(M) measurement with patches from Carl"
+ cd $pkgname
+ DESTDIR="${pkgdir}" ./waf install
+}