summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfabrixxm2024-04-24 16:23:29 +0200
committerfabrixxm2024-04-24 16:23:29 +0200
commitb4641470d2678bc2e46df7fca9deebeca6e9e378 (patch)
tree4baf2313ea94a309fe502619768ad0ed73a8409f
parent428efaab10bab20f9fe749e9db95fd684bda2597 (diff)
downloadaur-lesana.tar.gz
patch pyproject to not require setuptools-scm to get version
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--pyproject.toml.patch31
3 files changed, 41 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b8c897599f6b..bcf543f22ab0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lesana
pkgdesc = Manage collection inventories throught yaml files, develop version
pkgver = 0.10.1
- pkgrel = 1
+ pkgrel = 2
url = https://lesana.trueelena.org/
arch = any
license = AGPL-3.0-or-later
@@ -20,6 +20,8 @@ pkgbase = lesana
optdepends = sh: git integration
optdepends = python-gitpython: git integration
source = https://git.sr.ht/~valhalla/lesana/archive/v0.10.1.tar.gz
+ source = pyproject.toml.patch
sha256sums = 9e858cc10ba57132f10b16ecf32f54f8a0dc96783bf0283473340db4536c2e25
+ sha256sums = 0db3be7a5e6d0246fbc90dd0fc61c5d765cea49c03133c2a6ce4224ec1d6d2f5
pkgname = lesana
diff --git a/PKGBUILD b/PKGBUILD
index 70b8d211398e..391a54c782dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Fabrix Xm <fabrix.xm@gmail.com>
pkgname=lesana
pkgver=0.10.1
-pkgrel=1
+pkgrel=2
pkgdesc="Manage collection inventories throught yaml files, develop version"
arch=('any')
url="https://lesana.trueelena.org/"
@@ -14,18 +14,21 @@ optdepends=(
'python-gitpython: git integration'
)
makedepends=(python-build python-installer python-wheel)
-source=("https://git.sr.ht/~valhalla/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('9e858cc10ba57132f10b16ecf32f54f8a0dc96783bf0283473340db4536c2e25')
+source=("https://git.sr.ht/~valhalla/$pkgname/archive/v$pkgver.tar.gz" pyproject.toml.patch)
+sha256sums=('9e858cc10ba57132f10b16ecf32f54f8a0dc96783bf0283473340db4536c2e25'
+ '0db3be7a5e6d0246fbc90dd0fc61c5d765cea49c03133c2a6ce4224ec1d6d2f5')
prepare() {
cd "${pkgname}-v${pkgver}"
rm -fr dist/*.whl
+ # patch pyproject to not require setuptools-scm to get version
+ patch --forward --strip=1 --input=../pyproject.toml.patch
}
build() {
cd "${pkgname}-v${pkgver}"
- python -m build --wheel --no-isolation --skip-dependency-check
+ python -m build --wheel --no-isolation
}
package() {
diff --git a/pyproject.toml.patch b/pyproject.toml.patch
new file mode 100644
index 000000000000..9b7883547f1b
--- /dev/null
+++ b/pyproject.toml.patch
@@ -0,0 +1,31 @@
+--- a/pyproject.toml 2024-04-24 16:19:21.420395714 +0200
++++ b/pyproject.toml 2024-04-24 16:20:33.304790713 +0200
+@@ -1,9 +1,10 @@
+ [build-system]
+-requires = ["setuptools", "setuptools-scm"]
++requires = ["setuptools"]
+ build-backend = "setuptools.build_meta"
+
+ [project]
+ name = "lesana"
++version = "0.10.1"
+ authors = [
+ {name = "Elena ``of Valhalla'' Grandi", email = "valhalla@trueelena.org"},
+ ]
+@@ -34,7 +35,6 @@
+ "python-dateutil",
+ #"xapian >= 1.4",
+ ]
+-dynamic = ["version"]
+
+ [project.optional-dependencies]
+ cli = [
+@@ -54,8 +54,6 @@
+ Changelog = "https://git.sr.ht/~valhalla/lesana/tree/master/item/CHANGELOG.rst"
+ "Mailing lists" = "https://sr.ht/~valhalla/lesana/lists"
+
+-[tool.setuptools_scm]
+-version_file = "lesana/_version.py"
+
+ [[tool.mypy.overrides]]
+ module = [