summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfabrixxm2024-04-24 15:45:11 +0200
committerfabrixxm2024-04-24 15:45:11 +0200
commit428efaab10bab20f9fe749e9db95fd684bda2597 (patch)
tree1f35dd8609297de5abc0936b4fbf0c3fb47deadc
parentf0b8714584d3b976387140e0631c88e5b28d3c76 (diff)
downloadaur-428efaab10bab20f9fe749e9db95fd684bda2597.tar.gz
Update to lesana 0.10.1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7eb6bbec9adf..b8c897599f6b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lesana
pkgdesc = Manage collection inventories throught yaml files, develop version
- pkgver = 0.10.0
+ pkgver = 0.10.1
pkgrel = 1
url = https://lesana.trueelena.org/
arch = any
@@ -19,8 +19,7 @@ pkgbase = lesana
optdepends = git: git integration
optdepends = sh: git integration
optdepends = python-gitpython: git integration
- optdepends = python-requests: openlibrary integration
- source = https://git.sr.ht/~valhalla/lesana/archive/v0.10.0.tar.gz
- sha256sums = 5ca8edabe894f6d48f182920fd2ea44eba89d7bd2f2e8bbc1bfdfa04c9afd841
+ source = https://git.sr.ht/~valhalla/lesana/archive/v0.10.1.tar.gz
+ sha256sums = 9e858cc10ba57132f10b16ecf32f54f8a0dc96783bf0283473340db4536c2e25
pkgname = lesana
diff --git a/PKGBUILD b/PKGBUILD
index b53e59be93f7..70b8d211398e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Fabrix Xm <fabrix.xm@gmail.com>
pkgname=lesana
-pkgver=0.10.0
+pkgver=0.10.1
pkgrel=1
pkgdesc="Manage collection inventories throught yaml files, develop version"
arch=('any')
@@ -12,11 +12,11 @@ optdepends=(
'git: git integration'
'sh: git integration'
'python-gitpython: git integration'
- 'python-requests: openlibrary integration'
)
makedepends=(python-build python-installer python-wheel)
source=("https://git.sr.ht/~valhalla/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('5ca8edabe894f6d48f182920fd2ea44eba89d7bd2f2e8bbc1bfdfa04c9afd841')
+sha256sums=('9e858cc10ba57132f10b16ecf32f54f8a0dc96783bf0283473340db4536c2e25')
+
prepare() {
cd "${pkgname}-v${pkgver}"
@@ -31,7 +31,4 @@ build() {
package() {
cd "${pkgname}-v${pkgver}"
python -m installer --destdir="$pkgdir" dist/*.whl
- install -Dm0755 scripts/lesana ${pkgdir}/usr/bin/lesana
- install -Dm0755 scripts/openlibrary2lesana ${pkgdir}/usr/bin/openlibrary2lesana
- install -Dm0755 scripts/tellico2lesana ${pkgdir}/usr/bin/tellico2lesana
}