summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfabrixxm2024-04-24 15:23:31 +0200
committerfabrixxm2024-04-24 15:23:31 +0200
commitf0b8714584d3b976387140e0631c88e5b28d3c76 (patch)
treefa65ecd8774ce80fbda49c0d20a2e5ffd9fc866a
parent900aacf8bee06277d46f46b74700a22f4ef8e149 (diff)
downloadaur-f0b8714584d3b976387140e0631c88e5b28d3c76.tar.gz
Update to lesana 0.10.0
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD37
2 files changed, 38 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 130537104208..7eb6bbec9adf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,26 @@
pkgbase = lesana
- pkgdesc = Manage collection inventories throught yaml files
- pkgver = 0.9.1
- pkgrel = 2
+ pkgdesc = Manage collection inventories throught yaml files, develop version
+ pkgver = 0.10.0
+ pkgrel = 1
url = https://lesana.trueelena.org/
arch = any
- license = GPL3
- makedepends = python-setuptools
+ license = AGPL-3.0-or-later
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ depends = python
depends = python-dateutil
depends = python-jinja
depends = python-ruamel-yaml
depends = python-xapian
- depends = python-gitpython
- optdepends = python-argcomplete: support for bash autocompletion
- provides = lesana
- source = https://git.sr.ht/~valhalla/lesana/archive/v0.9.1.tar.gz
- md5sums = f0d166c71c5f9baa03b1815bd0d27d7a
+ depends = python-setuptools
+ depends = python-hazwaz
+ optdepends = python-argcomplete: enable commandline tab completion
+ optdepends = git: git integration
+ optdepends = sh: git integration
+ optdepends = python-gitpython: git integration
+ optdepends = python-requests: openlibrary integration
+ source = https://git.sr.ht/~valhalla/lesana/archive/v0.10.0.tar.gz
+ sha256sums = 5ca8edabe894f6d48f182920fd2ea44eba89d7bd2f2e8bbc1bfdfa04c9afd841
pkgname = lesana
diff --git a/PKGBUILD b/PKGBUILD
index 4048f151ea6d..b53e59be93f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,37 @@
# Maintainer: Fabrix Xm <fabrix.xm@gmail.com>
pkgname=lesana
-pkgver=0.9.1
-pkgrel=2
-pkgdesc="Manage collection inventories throught yaml files"
+pkgver=0.10.0
+pkgrel=1
+pkgdesc="Manage collection inventories throught yaml files, develop version"
arch=('any')
url="https://lesana.trueelena.org/"
-license=(GPL3)
-depends=('python-dateutil' 'python-jinja' 'python-ruamel-yaml' 'python-xapian' 'python-gitpython')
-optdepends=('python-argcomplete: support for bash autocompletion')
-makedepends=('python-setuptools')
-provides=(lesana)
+license=(AGPL-3.0-or-later)
+depends=('python' 'python-dateutil' 'python-jinja' 'python-ruamel-yaml' 'python-xapian' 'python-setuptools' 'python-hazwaz')
+optdepends=(
+ 'python-argcomplete: enable commandline tab completion'
+ 'git: git integration'
+ 'sh: git integration'
+ 'python-gitpython: git integration'
+ 'python-requests: openlibrary integration'
+)
+makedepends=(python-build python-installer python-wheel)
source=("https://git.sr.ht/~valhalla/$pkgname/archive/v$pkgver.tar.gz")
-md5sums=('f0d166c71c5f9baa03b1815bd0d27d7a')
+sha256sums=('5ca8edabe894f6d48f182920fd2ea44eba89d7bd2f2e8bbc1bfdfa04c9afd841')
prepare() {
- cd "${pkgname}-v${pkgver}"
- # exclude tests from package
- sed -i.bpk "s/find_packages()/find_packages(exclude=['tests',])/" setup.py
+ cd "${pkgname}-v${pkgver}"
+ rm -fr dist/*.whl
}
build() {
cd "${pkgname}-v${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation --skip-dependency-check
}
package() {
cd "${pkgname}-v${pkgver}"
- python setup.py install --skip-build --root="${pkgdir}" --optimize=1
- install scripts/openlibrary2lesana "${pkgdir}/usr/bin/"
- install scripts/tellico2lesana "${pkgdir}/usr/bin/"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm0755 scripts/lesana ${pkgdir}/usr/bin/lesana
+ install -Dm0755 scripts/openlibrary2lesana ${pkgdir}/usr/bin/openlibrary2lesana
+ install -Dm0755 scripts/tellico2lesana ${pkgdir}/usr/bin/tellico2lesana
}