summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfabrixxm2021-04-07 14:45:19 +0200
committerfabrixxm2021-04-07 14:45:19 +0200
commit1396347b107b456cbeda09d7afe46fd458f657ac (patch)
treec30d340f96d386d18f19dbaae3d427bbf81b8bb0
downloadaur-1396347b107b456cbeda09d7afe46fd458f657ac.tar.gz
First commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3c79eb53cf30
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = lesana-git
+ pkgdesc = Manage collection inventories throught yaml files, develop version
+ pkgver = v0.8.1.r22.gfea348c
+ pkgrel = 1
+ url = https://lesana.trueelena.org/
+ arch = x86_64
+ arch = aarch64
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python-dateutil
+ depends = python-jinja
+ depends = python-ruamel-yaml
+ depends = python-xapian
+ depends = python-gitpython
+ provides = lesana
+ source = git+https://git.sr.ht/~valhalla/lesana
+ md5sums = SKIP
+
+pkgname = lesana-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a90ad1e8ba17
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.pkg.tar.*
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1b5b967c9543
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Fabrix Xm <fabrix.xm@gmail.com>
+_pkgname=lesana
+pkgname=lesana-git
+pkgver=v0.8.1.r22.gfea348c
+pkgrel=1
+pkgdesc="Manage collection inventories throught yaml files, develop version"
+arch=('x86_64' 'aarch64')
+url="https://lesana.trueelena.org/"
+license=(GPL3)
+depends=('python-dateutil' 'python-jinja' 'python-ruamel-yaml' 'python-xapian' 'python-gitpython')
+makedepends=('python-setuptools')
+provides=(lesana)
+source=("git+https://git.sr.ht/~valhalla/lesana")
+md5sums=(SKIP)
+
+pkgver() {
+ cd "${_pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${_pkgname}"
+ sed -i.bpk "s/find_packages()/find_packages(exclude=['tests',])/" setup.py
+}
+
+build() {
+ cd "${_pkgname}"
+ python setup.py build
+}
+
+package() {
+ cd "${_pkgname}"
+ python setup.py install --skip-build --root="${pkgdir}" --optimize=1
+}