summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÓscar García Amor2023-01-25 21:11:48 +0100
committerÓscar García Amor2023-01-25 21:11:48 +0100
commit27d7f907d6702c47e470ab45c5232d0eb9aff857 (patch)
tree2656fe746934803494e87b0040f8171dae9fef0a
parentcb45c8e9b05f8099f3c1e0f30b9c9f2fe5de92ee (diff)
downloadaur-27d7f907d6702c47e470ab45c5232d0eb9aff857.tar.gz
upgpkg: lesma 0.8.0-1
upstream release
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
-rw-r--r--lesma.toml55
3 files changed, 8 insertions, 66 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b5c91b11534..f5ecfb545881 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lesma
pkgdesc = A small and ultrasecure Lesspass database server written in Rust
- pkgver = 0.7.1
+ pkgver = 0.8.0
pkgrel = 1
url = https://gitlab.com/ogarcia/lesma
arch = arm
@@ -14,11 +14,9 @@ pkgbase = lesma
depends = gcc-libs
options = !lto
backup = etc/lesma.toml
- source = https://gitlab.com/ogarcia/lesma/-/archive/0.7.1/lesma-0.7.1.tar.bz2
- source = lesma.toml
+ source = https://gitlab.com/ogarcia/lesma/-/archive/0.8.0/lesma-0.8.0.tar.bz2
source = lesma.service
- b2sums = 5105817d6f3cb62ec737ebeb8cd7f7aabd269256a2b8be0b0ee9dab51a478658654f14c69150667b13bce1b19b4dbda26393487e189ff10d00b3a7afdc4e6844
- b2sums = 669031b846b817a48e7aa621df34fbf85102e8da6ab58e77ab6ac4abbb77d3632933881116f256e49a22cff3ecd52712ce9e34f451cef778d8e61762ad3609d2
+ b2sums = 934aac8ba04c0e5a031b1eae5fded1e51ba9ae08eb8fd3de83495627f6454bcf98727f4487f25fff57f325e8f193100131761f6e5ba6e1ef01fdc0bbb0fb5f86
b2sums = 6512f2d4fc6852cbcb96469890d15ab922d46eeeb6f25b234b074966f3a17b5748936fd5898a0e3c914b59f5b526595cff17f8abc856e58fb5cb4acd83ef2515
pkgname = lesma
diff --git a/PKGBUILD b/PKGBUILD
index 97a2cbe1ef17..7fa78eeafdf4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: "Amhairghin" Oscar Garcia Amor (https://ogarcia.me)
pkgname=lesma
-pkgver=0.7.1
+pkgver=0.8.0
pkgrel=1
pkgdesc='A small and ultrasecure Lesspass database server written in Rust'
arch=('arm' 'armv6h' 'armv7h' 'aarch64' 'i686' 'x86_64')
@@ -12,10 +12,8 @@ makedepends=('rust')
options=('!lto')
backup=("etc/${pkgname}.toml")
source=("https://gitlab.com/ogarcia/${pkgname}/-/archive/${pkgver}/${pkgname}-${pkgver}.tar.bz2"
- "${pkgname}.toml"
"${pkgname}.service")
-b2sums=('5105817d6f3cb62ec737ebeb8cd7f7aabd269256a2b8be0b0ee9dab51a478658654f14c69150667b13bce1b19b4dbda26393487e189ff10d00b3a7afdc4e6844'
- '669031b846b817a48e7aa621df34fbf85102e8da6ab58e77ab6ac4abbb77d3632933881116f256e49a22cff3ecd52712ce9e34f451cef778d8e61762ad3609d2'
+b2sums=('934aac8ba04c0e5a031b1eae5fded1e51ba9ae08eb8fd3de83495627f6454bcf98727f4487f25fff57f325e8f193100131761f6e5ba6e1ef01fdc0bbb0fb5f86'
'6512f2d4fc6852cbcb96469890d15ab922d46eeeb6f25b234b074966f3a17b5748936fd5898a0e3c914b59f5b526595cff17f8abc856e58fb5cb4acd83ef2515')
build() {
@@ -27,10 +25,11 @@ package() {
# binary
install -Dm755 "${srcdir}/${pkgbase}-${pkgver}/target/release/${pkgname}" \
"${pkgdir}/usr/bin/${pkgname}"
- # conf
- install -Dm644 "${srcdir}/${pkgname}.toml" "${pkgdir}/etc/${pkgname}.toml"
# service
install -Dm644 "${srcdir}/${pkgname}.service" "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
+ # conf
+ install -Dm644 "${srcdir}/${pkgbase}-${pkgver}/${pkgname}.toml.example" \
+ "${pkgdir}/etc/${pkgname}.toml"
# templates and static directories
install -dm755 "${pkgdir}/usr/lib/${pkgname}"
cp -r "${srcdir}/${pkgbase}-${pkgver}/templates" \
diff --git a/lesma.toml b/lesma.toml
deleted file mode 100644
index 43f038b6da37..000000000000
--- a/lesma.toml
+++ /dev/null
@@ -1,55 +0,0 @@
-# You can have several different profiles and use LESMA_PROFILE environment
-# variable to switch between them. By default release is used.
-# See https://rocket.rs/v0.5-rc/guide/configuration/#profiles for more info.
-#
-# All configuration parameters can also be set with environment variables.
-# For each parameter, the corresponding environment variable is indicated.
-# Note that all parameters are optional, if not defined the default values
-# are used.
-#
-# If you want to use this configuration file, copy it as /etc/lesma.toml or
-# as lesma.toml together with the executable file.
-[release]
-# Listen address, default 127.0.0.1
-# LESMA_ADDRESS
-address = "127.0.0.1"
-# Listen port, default 8000
-# LESMA_PORT
-#port = 8000
-# When a new URL for a paste or file is generated use http or https, by
-# default is set to false and uses http
-# LESMA_HTTPS
-https=true
-# Log level, the valid values are `critical`, `normal`, `debug`, `off`, if
-# not defined the default value is off
-# LESMA_LOG_LEVEL
-#log_level = "normal"
-# The size limit sets both the limit for uploaded files and for the
-# information posted, default 10MiB. If you simply indicate a number the
-# size is in bytes but you can use the suffixes kB, MB, GB.. for powers of
-# ten or KiB, MiB, GiB.. for powers of two
-# LESMA_SIZE_LIMIT
-#size_limit = "5GiB"
-# Default download limit for every paste or file created where a different
-# value is not specified , default 0 (unlimited), maximum accepted value 255
-# LESMA_DEFAULT_LIMIT
-#default_limit = 1
-# Default expiration time (in hours) for each paste or file created when
-# a different value is not specified, default 720 hours (30 days)
-# LESMA_DEFAULT_EXPIRE
-#default_expire = 24
-# Maximum expiration time that an user can set (in hours) for each paste or
-# file, default 720 hours (30 days)
-# LESMA_MAX_EXPIRE
-#max_expire = 168
-# Location of lesmas storage, if not defined, a temporary directory will be
-# used, usually /tmp
-# LESMA_STORAGE
-storage = "/var/lib/lesma"
-
-# Other sample
-#[debug]
-#address = "127.0.0.1"
-#port = 9000
-#log_level = "debug"
-#storage = "/tmp/lesma"