summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12022-09-04 23:19:23 +0800
committerChocobo12022-09-04 23:40:20 +0800
commitebbd3daf2e66625792abed1ceceb95170a847dd4 (patch)
tree69af8565f6e58328025d8470a4db0c587d28837d
downloadaur-ebbd3daf2e66625792abed1ceceb95170a847dd4.tar.gz
newpkg: less-git 608.r0.g22e4af5-1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD51
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f692928128ed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = less-git
+ pkgdesc = A free, open-source file pager
+ pkgver = 608.r0.g22e4af5
+ pkgrel = 1
+ url = https://greenwoodsoftware.com/less/
+ arch = i686
+ arch = x86_64
+ license = custom
+ license = GPL3
+ makedepends = git
+ makedepends = perl
+ depends = glibc
+ depends = ncurses
+ depends = pcre2
+ provides = less=608.r0.g22e4af5
+ conflicts = less
+ source = git+https://github.com/gwsw/less.git
+ sha256sums = SKIP
+
+pkgname = less-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2150c0034548
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=less-git
+pkgver=608.r0.g22e4af5
+pkgrel=1
+pkgdesc="A free, open-source file pager"
+arch=('i686' 'x86_64')
+url="https://greenwoodsoftware.com/less/"
+license=('custom' 'GPL3')
+depends=('glibc' 'ncurses' 'pcre2')
+makedepends=('git' 'perl')
+provides=("less=$pkgver")
+conflicts=('less')
+source=("git+https://github.com/gwsw/less.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "less"
+
+ _tag=$(git tag -l --sort -v:refname | sed '/rc[0-9]*/d' | head -n1)
+ _rev=$(git rev-list --count $_tag..HEAD)
+ _hash=$(git rev-parse --short HEAD)
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^v//'
+}
+
+build() {
+ cd "less"
+
+ make -f Makefile.aut \
+ distfiles \
+ all
+ ./configure \
+ --prefix="/usr" \
+ --sysconfdir="/etc" \
+ --with-regex=pcre2
+ make
+}
+
+check() {
+ cd "less"
+
+ make check
+}
+
+package() {
+ cd "less"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "LICENSE" -t "$pkgdir/usr/share/licenses/less"
+}