summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEyaz Omarjee2016-04-04 16:26:36 +0400
committerEyaz Omarjee2016-04-04 16:26:36 +0400
commit081364c7b5c2fcd389001b225676b971e5c7feb5 (patch)
tree81952061bf411a3e4f10bbc8ad60ba52be6ae0b3
downloadaur-081364c7b5c2fcd389001b225676b971e5c7feb5.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
-rwxr-xr-xlessmsi12
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aeae8b6e4afa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = lessmsi
+ pkgdesc = An utility to view and extract the contents of an MSI file
+ pkgver = 1.4
+ pkgrel = 1
+ url = http://lessmsi.activescott.com
+ arch = any
+ makedepends = gendesk
+ makedepends = icoutils
+ depends = winetricks
+ source = https://github.com/activescott/lessmsi/releases/download/v1.4/lessmsi-v1.4.zip
+ source = lessmsi
+ sha1sums = 3798775e8038e5ae9d1b279cca7df234ee4ca560
+ sha1sums = 6b5308768269d0846104abf83fae3b5aa71b77d1
+
+pkgname = lessmsi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f042c8ad58f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+pkgname=lessmsi
+pkgver=1.4
+pkgrel=1
+pkgdesc='An utility to view and extract the contents of an MSI file'
+arch=(any)
+url='http://lessmsi.activescott.com'
+depends=(winetricks)
+makedepends=(gendesk icoutils)
+source=(https://github.com/activescott/lessmsi/releases/download/v$pkgver/lessmsi-v$pkgver.zip
+ lessmsi)
+sha1sums=('3798775e8038e5ae9d1b279cca7df234ee4ca560'
+ '6b5308768269d0846104abf83fae3b5aa71b77d1')
+
+prepare() {
+ cd $srcdir
+ gendesk -f -n --pkgname "$pkgname" --pkgdesc "$pkgdesc" --categories 'Wine'
+}
+
+package() {
+ cd $srcdir
+ install -d $pkgdir/usr/share/$pkgname
+ find . ! -name lessmsi-v$pkgver.zip \
+ ! -name lessmsi.desktop \
+ ! -name lessmsi \
+ ! -name . \
+ -exec install -m644 -t $pkgdir/usr/share/$pkgname {} +
+ install -Dm755 lessmsi $pkgdir/usr/bin/lessmsi
+ install -Dm644 lessmsi.desktop $pkgdir/usr/share/applications/lessmsi.desktop
+}
+
diff --git a/lessmsi b/lessmsi
new file mode 100755
index 000000000000..6bc2e7152b35
--- /dev/null
+++ b/lessmsi
@@ -0,0 +1,12 @@
+#!/usr/bin/env sh
+
+export WINEARCH=win32 WINEPREFIX=$HOME/.wine32
+
+winetricks -q dotnet45
+
+if [ $(uname -m) = 'x86_64' ]; then
+ LD_PRELOAD=/usr/lib32/libjpeg.so.62 wine /usr/share/lessmsi/lessmsi.exe $@
+else
+ wine /usr/share/lessmsi/lessmsi.exe $@
+fi
+