summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaphaël Doursenaud2017-02-17 16:44:51 +0100
committerRaphaël Doursenaud2017-02-17 16:44:51 +0100
commit36b9effd8bf0ea6f1fd191590f6f91d7e14953c2 (patch)
tree21a88d5bf417d467fe0cc4ab0863f9c80c324405
downloadaur-36b9effd8bf0ea6f1fd191590f6f91d7e14953c2.tar.gz
First package
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD62
2 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..100f76351992
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Fri Feb 17 15:44:51 UTC 2017
+pkgbase = letsencrypt-gandi-git
+ pkgdesc = Gandi plugin for Let's Encrypt
+ pkgver = r31.4f724cd
+ pkgrel = 1
+ url = https://github.com/Gandi/letsencrypt-gandi
+ arch = any
+ license = APACHE
+ makedepends = git
+ makedepends = python2-setuptools
+ makedepends = python2-mock
+ depends = certbot
+ source = git+https://github.com/Gandi/letsencrypt-gandi
+ md5sums = SKIP
+
+pkgname = letsencrypt-gandi-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a3e6fb9f4ee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: Raphaël Doursenaud <rdoursenaud@gmail.com>
+pkgname=letsencrypt-gandi-git
+pkgver=r31.4f724cd
+pkgrel=1
+pkgdesc="Gandi plugin for Let's Encrypt"
+arch=(any)
+url="https://github.com/Gandi/letsencrypt-gandi"
+license=('APACHE')
+groups=()
+depends=('certbot')
+makedepends=('git' 'python2-setuptools' 'python2-mock')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=('git+https://github.com/Gandi/letsencrypt-gandi')
+noextract=()
+md5sums=('SKIP')
+
+_gitroot=https://github.com/Gandi/letsencrypt-gandi
+_gitname=letsencrypt-gandi
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [[ -d "$_gitname" ]]; then
+ cd "$_gitname" && git pull origin master
+ msg "The local files are updated."
+ else
+ git clone "$_gitroot" "$_gitname"
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting build..."
+
+ rm -rf "$srcdir/$_gitname-build"
+ git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+ cd "$srcdir/$_gitname-build"
+ python2 setup.py build
+}
+
+pkgver() {
+ cd "$_gitname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+check() {
+ cd "$srcdir/$_gitname-build"
+ python2 setup.py test
+}
+
+package() {
+ cd "$srcdir/$_gitname-build"
+ python2 setup.py install --optimize=1 --root="$pkgdir/"
+}
+
+# vim:set ts=2 sw=2 et: