summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-04-02 11:12:41 -0600
committerMark Wagie2024-04-02 11:12:41 -0600
commit93c3627ba85b29bfb080987e308b523a068a4281 (patch)
tree1bdf78c3997b295f46439b93361fcc3df4d20b0f
parent96a5667c1a127b2e60c2031c87e179175fe8ec6b (diff)
downloadaur-93c3627ba85b29bfb080987e308b523a068a4281.tar.gz
2.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD16
2 files changed, 16 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0dcdba3d316b..75248f501c6c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = letterpress
- pkgdesc = Uses jp2a to turn your pictures into images made up of ASCII Characters.
- pkgver = 1.3.0
+ pkgdesc = Uses artem to turn your pictures into images made up of ASCII Characters.
+ pkgver = 2.0
pkgrel = 1
- url = https://gitlab.com/gregorni/Letterpress
+ url = https://gitlab.gnome.org/World/Letterpress
arch = any
- license = GPL3
+ license = GPL-3.0-or-later
checkdepends = appstream-glib
makedepends = blueprint-compiler
makedepends = meson
- depends = jp2a
+ depends = artem
depends = libadwaita
depends = python-gobject
- source = https://gitlab.com/gregorni/Letterpress/-/archive/1.3.0/Letterpress-1.3.0.tar.gz
- sha256sums = f6f64c2c4df15bcbb5a41feac478593dc69f8fae8ea20a279166d967dfec6b6a
+ depends = python-pillow
+ source = https://gitlab.gnome.org/World/Letterpress/-/archive/2.0/Letterpress-2.0.tar.gz
+ sha256sums = 34c457f30af4eeb58785d125eb596859abc64a519625829d69008d10581b1951
pkgname = letterpress
diff --git a/PKGBUILD b/PKGBUILD
index e3c91592ac81..ce53e5d0f106 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=letterpress
-pkgver=1.3.0
+pkgver=2.0
pkgrel=1
-pkgdesc="Uses jp2a to turn your pictures into images made up of ASCII Characters."
+pkgdesc="Uses artem to turn your pictures into images made up of ASCII Characters."
arch=('any')
-url="https://gitlab.com/gregorni/Letterpress"
-license=('GPL3')
-depends=('jp2a' 'libadwaita' 'python-gobject')
+url="https://gitlab.gnome.org/World/Letterpress"
+license=('GPL-3.0-or-later')
+depends=('artem' 'libadwaita' 'python-gobject' 'python-pillow')
makedepends=('blueprint-compiler' 'meson')
checkdepends=('appstream-glib')
-source=("https://gitlab.com/gregorni/Letterpress/-/archive/$pkgver/Letterpress-$pkgver.tar.gz")
-sha256sums=('f6f64c2c4df15bcbb5a41feac478593dc69f8fae8ea20a279166d967dfec6b6a')
+source=("https://gitlab.gnome.org/World/Letterpress/-/archive/$pkgver/Letterpress-$pkgver.tar.gz")
+sha256sums=('34c457f30af4eeb58785d125eb596859abc64a519625829d69008d10581b1951')
build() {
arch-meson "Letterpress-$pkgver" build
@@ -18,7 +18,7 @@ build() {
}
check() {
- meson test -C build --print-errorlogs || :
+ meson test -C build --print-errorlogs
}
package() {