summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-04-02 11:03:22 -0600
committerMark Wagie2024-04-02 11:03:22 -0600
commit96a5667c1a127b2e60c2031c87e179175fe8ec6b (patch)
tree86c2cf93130d632980f013e093a15f8ca0681c0a
downloadaur-96a5667c1a127b2e60c2031c87e179175fe8ec6b.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD26
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0dcdba3d316b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = letterpress
+ pkgdesc = Uses jp2a to turn your pictures into images made up of ASCII Characters.
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = https://gitlab.com/gregorni/Letterpress
+ arch = any
+ license = GPL3
+ checkdepends = appstream-glib
+ makedepends = blueprint-compiler
+ makedepends = meson
+ depends = jp2a
+ depends = libadwaita
+ depends = python-gobject
+ source = https://gitlab.com/gregorni/Letterpress/-/archive/1.3.0/Letterpress-1.3.0.tar.gz
+ sha256sums = f6f64c2c4df15bcbb5a41feac478593dc69f8fae8ea20a279166d967dfec6b6a
+
+pkgname = letterpress
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e3c91592ac81
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
+pkgname=letterpress
+pkgver=1.3.0
+pkgrel=1
+pkgdesc="Uses jp2a to turn your pictures into images made up of ASCII Characters."
+arch=('any')
+url="https://gitlab.com/gregorni/Letterpress"
+license=('GPL3')
+depends=('jp2a' 'libadwaita' 'python-gobject')
+makedepends=('blueprint-compiler' 'meson')
+checkdepends=('appstream-glib')
+source=("https://gitlab.com/gregorni/Letterpress/-/archive/$pkgver/Letterpress-$pkgver.tar.gz")
+sha256sums=('f6f64c2c4df15bcbb5a41feac478593dc69f8fae8ea20a279166d967dfec6b6a')
+
+build() {
+ arch-meson "Letterpress-$pkgver" build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs || :
+}
+
+package() {
+ meson install -C build --destdir "$pkgdir"
+}