summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Keen2015-08-08 23:30:22 -0400
committerKyle Keen2015-08-08 23:30:22 -0400
commit821c087ecc43d890ef3af2e29559a8dc8d6690a5 (patch)
treed93ab0d72a7bde970c9c0c7a6bbc222b01352d5e
downloadaur-821c087ecc43d890ef3af2e29559a8dc8d6690a5.tar.gz
aur3 recovery
-rw-r--r--.SRCINFO17
-rw-r--r--COPYING15
-rw-r--r--PKGBUILD34
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3bcc4f0c2964
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = levee
+ pkgdesc = A small, modal text editor based on vi
+ pkgver = 3.5b
+ pkgrel = 1
+ url = http://www.pell.portland.or.us/~orc/Code/levee/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = ncurses
+ conflicts = lv
+ source = http://www.pell.portland.or.us/~orc/Code/levee/levee-3.5b.tar.bz2
+ source = COPYING
+ md5sums = fc19744ef17e980de9a4cc27fbaaeb90
+ md5sums = c3c3b5129975a2e707e2870735753853
+
+pkgname = levee
+
diff --git a/COPYING b/COPYING
new file mode 100644
index 000000000000..de89829992ec
--- /dev/null
+++ b/COPYING
@@ -0,0 +1,15 @@
+Copyright (c) 1982-2007 David L Parsons
+All rights reserved.
+
+Redistribution and use in source and binary forms, without or
+without modification, are permitted provided that the above
+copyright notice and this paragraph are duplicated in all such
+forms and that any documentation, advertising materials, and
+other materials related to such distribution and use acknowledge
+that the software was developed by David L Parsons (orc@pell.chi.il.us).
+My name may not be used to endorse or promote products derived
+from this software without specific prior written permission.
+THIS SOFTWARE IS PROVIDED AS IS'' AND WITHOUT ANY EXPRESS OR
+IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
+WARRANTIES OF MERCHANTIBILITY AND FITNESS FOR A PARTICULAR
+PURPOSE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..895ad5f84df2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: TDY <tdy@archlinux.info>
+
+pkgname=levee
+pkgver=3.5b
+pkgrel=1
+pkgdesc="A small, modal text editor based on vi"
+arch=('i686' 'x86_64')
+url="http://www.pell.portland.or.us/~orc/Code/levee/"
+license=('MIT')
+depends=('ncurses')
+conflicts=('lv') # see the build() function
+source=(http://www.pell.portland.or.us/~orc/Code/$pkgname/$pkgname-$pkgver.tar.bz2
+ COPYING)
+md5sums=('fc19744ef17e980de9a4cc27fbaaeb90'
+ 'c3c3b5129975a2e707e2870735753853')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # An 'lv' link is created for convenience, conflicting with the 'lv' package.
+ # Uncomment the next line to skip the symlink if you also want the 'lv' package.
+ #sed -i '/LN_S/d' Makefile.in
+
+ ./configure.sh --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX="$pkgdir" install
+ install -Dm644 ../COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
+
+# vim:set ts=2 sw=2 et: