summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZeph332016-06-17 18:43:57 +0100
committerZeph332016-06-17 18:43:57 +0100
commit8cb3af0a806c8648a4d7a8989e7c24e63c2303bd (patch)
treec2bd2ea238820ebe0bed976403e76999097ef9b0
parent9b59d2cd7f35fa9bf60d887831f045439a355210 (diff)
downloadaur-8cb3af0a806c8648a4d7a8989e7c24e63c2303bd.tar.gz
Add i686 support
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD20
-rw-r--r--lexmark_pro700.install17
3 files changed, 34 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d638a7933d2..e1a191bfc69e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,13 @@
+# Generated by mksrcinfo v8
+# Fri Jun 17 17:36:44 UTC 2016
pkgbase = lexmark_pro700
pkgdesc = Lexmark Pro700 Series Printer Driver
pkgver = 1.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.lexmark.com/
install = lexmark_pro700.install
arch = x86_64
+ arch = i686
license = Freeware
makedepends = rpmextract
makedepends = gzip
diff --git a/PKGBUILD b/PKGBUILD
index fb59dbf5eeba..c86ce6d8be16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,34 @@
# For Lexmark Pro700 Series
pkgname=lexmark_pro700
pkgver=1.0
-pkgrel=1
+pkgrel=2
pkgdesc="Lexmark Pro700 Series Printer Driver"
makedepends=('rpmextract' 'gzip' 'bash')
depends=('java-runtime' 'cups' 'libstdc++5' 'lua')
-arch=('x86_64')
+arch=('x86_64' 'i686')
license=('Freeware')
+if [[ $CARCH == i686 ]]; then
+ _arch='i386'
+ md5sums=('421a5461e8cc04f1b838d23e868448fc')
+else
+ _arch='x86_64'
+ md5sums=('fc421f21e50a40a4ba482c0b04f17b84')
+fi
install=lexmark_pro700.install
url="http://www.lexmark.com/"
-source=("http://downloads.lexmark.com/downloads/cpd/lexmark-inkjet-legacy-1.0-1.x86_64.rpm.sh.tar.gz")
-md5sums=('fc421f21e50a40a4ba482c0b04f17b84')
+source=("http://downloads.lexmark.com/downloads/cpd/lexmark-inkjet-legacy-1.0-1.${_arch}.rpm.sh.tar.gz")
prepare() {
# cd $startdir/src
# tar xf lexmark-inkjet-legacy-1.0-1.x86_64.rpm.sh.tar.gz
cd ${srcdir}
- sh lexmark-inkjet-legacy-1.0-1.x86_64.rpm.sh --noexec --target Installer-Files
+ sh lexmark-inkjet-legacy-1.0-1.${_arch}.rpm.sh --noexec --target Installer-Files
cd Installer-Files
mkdir Driver
tar xvvf instarchive_all --lzma -C Driver/
cd Driver
- rpmextract.sh lexmark-inkjet-legacy-1.0-1.x86_64.rpm
- rpmextract.sh lexmark-legacy-wsu-1.0-1.x86_64.rpm
+ rpmextract.sh lexmark-inkjet-legacy-1.0-1.${_arch}.rpm
+ rpmextract.sh lexmark-legacy-wsu-1.0-1.${_arch}.rpm
}
package(){
diff --git a/lexmark_pro700.install b/lexmark_pro700.install
index e3a8681da55a..e3ae8909d199 100644
--- a/lexmark_pro700.install
+++ b/lexmark_pro700.install
@@ -434,6 +434,23 @@ post_install() {
ls /usr/share/applications | grep desktop | grep cache | xargs -ti cp /tmp/app /usr/share/applications/{} > /dev/null 2>&1
rm /tmp/app
fi
+ echo ""
+ echo ""
+ echo ""
+ echo "==============================================================================="
+ echo "== Check cups is started : =="
+ echo "== systemctl status org.cups.cupsd.service =="
+ echo "== =="
+ echo "== If not, start cups : =="
+ echo "== sudo systemctl start org.cups.cupsd.service =="
+ echo "== For start cups at boot : =="
+ echo "== sudo systemctl enable org.cups.cupsd.service =="
+ echo "== =="
+ echo "== Install your printer with cups : http://localhost:631 =="
+ echo "== Select ppd file in =="
+ echo "== /usr/share/cups/model/Lexmark =="
+ echo "== /usr/share/ppd/Lexmark =="
+ echo "==============================================================================="
}
#post_upgrade() {