summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlexofficial292021-02-08 10:17:20 +0200
committerlexofficial292021-02-08 10:17:20 +0200
commitd298379b2c252c98a65c78b979681ba6f6d285d7 (patch)
tree871b4ae23a6094cb94187d448a4ef69b709ad682
downloadaur-d298379b2c252c98a65c78b979681ba6f6d285d7.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..60816f75f525
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = lexspec-git
+ pkgdesc = Get system information in linux
+ pkgver = r10.5ac67ac
+ pkgrel = 1
+ url = https://github.com/lexofficial29/lexspec
+ arch = any
+ license = GPLv2
+ provides = lexspec
+ conflicts = lexspec
+ source = git+https://github.com/lexofficial29/lexspec
+ md5sums = SKIP
+
+pkgname = lexspec-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0fbe31bf3340
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Eduard Gabriel (lexofficial29@protonmail.com)
+
+pkgname=lexspec-git
+_srcname=lexspec
+provides=('lexspec')
+conflicts=('lexspec')
+pkgver=r10.5ac67ac
+pkgrel=1
+pkgdesc="Get system information in linux"
+arch=('any')
+url="https://github.com/lexofficial29/lexspec"
+license=('GPLv2')
+source=("git+https://github.com/lexofficial29/lexspec")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_srcname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgdir"
+ install -Dm644 "$srcdir"/"$_srcname"/lspec usr/bin/lspec
+ chmod +x usr/bin/lspec
+}