summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-09-18 21:22:40 +0200
committerhaawda2018-09-18 21:22:40 +0200
commit7f448411b1f3bbf6d6347fae0765b2a50ed83384 (patch)
treee911e9bc6d057fd8ac20571fd068caa43eac3d12
parent108b49693ccbb6ee6151c5ae67ae8d0e3ac32928 (diff)
downloadaur-7f448411b1f3bbf6d6347fae0765b2a50ed83384.tar.gz
update
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD24
2 files changed, 13 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5b8bd1207e5c..7ab32d788365 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = lf
pkgdesc = lf is a terminal file manager written in Go
- pkgver = r7
+ pkgver = 8
pkgrel = 1
url = https://github.com/gokcehan/lf
arch = i686
arch = x86_64
license = MIT
makedepends = git
- makedepends = go>=1.6
+ makedepends = go-pie
depends = glibc
- source = git+https://github.com/gokcehan/lf.git#commit=ffa913d9431574da81bd90fb6fb9e8566823dbe
- sha256sums = SKIP
+ source = lf-r8.tar.gz::https://github.com/gokcehan/lf/archive/r8.tar.gz
+ sha256sums = b92bfba41cc1b4054c44bf615907380482c66694fc9eaf4affe185b39cb9bb26
pkgname = lf
diff --git a/PKGBUILD b/PKGBUILD
index 471414421d2f..61488079de62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,32 +2,26 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=lf
-pkgver=r7
+pkgver=8
pkgrel=1
license=('MIT')
pkgdesc='lf is a terminal file manager written in Go'
depends=("glibc")
-makedepends=("git" "go>=1.6")
-arch=("i686" "x86_64")
+makedepends=('git' 'go-pie')
+arch=('i686' 'x86_64')
_gourl='github.com/gokcehan/lf'
url="https://${_gourl}"
-source=("git+https://github.com/gokcehan/lf.git#commit=ffa913d9431574da81bd90fb6fb9e8566823dbe")
-sha256sums=('SKIP')
-
-pkgver() {
- cd "${srcdir}/${pkgname}"
- git describe --tags |tr - .
-}
+source=("$pkgname-r$pkgver.tar.gz::https://github.com/gokcehan/$pkgname/archive/r$pkgver.tar.gz")
+sha256sums=('b92bfba41cc1b4054c44bf615907380482c66694fc9eaf4affe185b39cb9bb26')
build() {
- cd "${srcdir}/${pkgname}"
- GOPATH="${srcdir}/go" go get -u "${_gourl}"
- GOPATH="${srcdir}/go" go build
+ cd ${pkgname}-r$pkgver
+ go build
}
package() {
- cd "${srcdir}/${pkgname}"
- install -Dm755 ./lf "${pkgdir}"/usr/bin/lf
+ cd ${pkgname}-r$pkgver
+ install -Dm755 lf-r$pkgver "${pkgdir}"/usr/bin/lf
install -Dm644 ./LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
install -Dm644 ./README.md "${pkgdir}"/usr/share/doc/${pkgname}/README.md
}