summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Rabert2019-11-01 23:57:30 -0400
committerAndrew Rabert2019-11-01 23:57:30 -0400
commite31211bbaca0138b96f5716fcf1c5519f1d665fc (patch)
tree2d9028fdcea466ab0ea7f1e5d10bd969e08a6323
parent9e52409feaf0163c9829f912d6e8fdba67ca4c6c (diff)
downloadaur-e31211bbaca0138b96f5716fcf1c5519f1d665fc.tar.gz
Also remove modcache in prepare
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3fb0cdfdce84..0363368ba56d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,11 +16,15 @@ source=("$pkgname-r$pkgver.tar.gz::https://github.com/gokcehan/$pkgname/archive/
sha256sums=('fe99ed9785fbdc606835139c0c52c854b32b1f1449ba83567a115b21d2e882f4')
_srcname=${pkgname}-r$pkgver
-build() {
+prepare() {
# prevent creation of a `go` directory in one's home.
# this directory cannot be removed with even `rm -rf` unless one becomes root
# or changes the write permissions.
export GOPATH="${srcdir}/gopath"
+ go clean -modcache
+}
+
+build() {
cd "${pkgname}-r${pkgver}"
go mod vendor
version=r$pkgver ./gen/build.sh -mod=vendor -trimpath