summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2018-06-04 01:52:00 +0200
committerNarrat2018-06-04 01:54:01 +0200
commitf64c8a049633079edab96ab7d1b2814525809c81 (patch)
tree88eb58631341cb08b34e096100f9a29fa2ea3916
parent82a472514783994b1f2ce4f74b8494a50ac6fbc8 (diff)
downloadaur-f64c8a049633079edab96ab7d1b2814525809c81.tar.gz
lf: update to r4
Changes include: * Removal of README.md * Update download URL and pkgver * Remove unnecessary provides
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD19
-rw-r--r--README.md97
3 files changed, 17 insertions, 116 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a5659e9f5325..97f12bb59b50 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,20 @@
pkgbase = lf
pkgdesc = lf: A terminal file manager, heavily inspired by ranger (Precompiled binary from official repository)
- pkgver = nightly
- pkgrel = 5
+ pkgver = 4
+ pkgrel = 1
url = https://github.com/gokcehan/lf
arch = i686
arch = x86_64
arch = armv7h
license = MIT
- provides = lf
options = !strip
options = !emptydirs
- source_i686 = https://github.com/gokcehan/lf/releases/download/nightly/lf-linux-386.tar.gz
- md5sums_i686 = e5d8a5b95d8f10020e7cfb8031ad08ce
- source_x86_64 = https://github.com/gokcehan/lf/releases/download/nightly/lf-linux-amd64.tar.gz
- md5sums_x86_64 = 570984e7368fe2c551fa7a0d926e863f
- source_armv7h = https://github.com/gokcehan/lf/releases/download/nightly/lf-linux-arm.tar.gz
- md5sums_armv7h = 2dbf95dcfb0133a4b6705a3b80340636
+ source_i686 = https://github.com/gokcehan/lf/releases/download/r4/lf-linux-386.tar.gz
+ md5sums_i686 = 208d736544a2eadb3ceaad6000932dce
+ source_x86_64 = https://github.com/gokcehan/lf/releases/download/r4/lf-linux-amd64.tar.gz
+ md5sums_x86_64 = e8c9fe971c41a428bf302e00f077fe26
+ source_armv7h = https://github.com/gokcehan/lf/releases/download/r4/lf-linux-arm.tar.gz
+ md5sums_armv7h = 0a6a42df17202bbee767cbbace27726f
pkgname = lf
diff --git a/PKGBUILD b/PKGBUILD
index 503ddb516b10..25622f48f0a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,19 @@
-# Maintainer: Dany Marcoux <danymarcoux+archlinux@gmail.com>
+# Contributor: Dany Marcoux <danymarcoux+archlinux@gmail.com>
pkgname=lf
-pkgver=nightly
-pkgrel=5
+pkgver=4
+pkgrel=1
pkgdesc='lf: A terminal file manager, heavily inspired by ranger (Precompiled binary from official repository)'
arch=('i686' 'x86_64' 'armv7h')
url='https://github.com/gokcehan/lf'
license=('MIT') # https://github.com/gokcehan/lf/blob/master/LICENSE
options=('!strip' '!emptydirs')
-provides=('lf')
-source_i686=("https://github.com/gokcehan/lf/releases/download/$pkgver/lf-linux-386.tar.gz")
-source_x86_64=("https://github.com/gokcehan/lf/releases/download/$pkgver/lf-linux-amd64.tar.gz")
-source_armv7h=("https://github.com/gokcehan/lf/releases/download/$pkgver/lf-linux-arm.tar.gz")
-md5sums_i686=('e5d8a5b95d8f10020e7cfb8031ad08ce')
-md5sums_x86_64=('570984e7368fe2c551fa7a0d926e863f')
-md5sums_armv7h=('2dbf95dcfb0133a4b6705a3b80340636')
+source_i686=("${url}/releases/download/r${pkgver}/lf-linux-386.tar.gz")
+source_x86_64=("${url}/releases/download/r${pkgver}/lf-linux-amd64.tar.gz")
+source_armv7h=("${url}/releases/download/r${pkgver}/lf-linux-arm.tar.gz")
+md5sums_i686=('208d736544a2eadb3ceaad6000932dce')
+md5sums_x86_64=('e8c9fe971c41a428bf302e00f077fe26')
+md5sums_armv7h=('0a6a42df17202bbee767cbbace27726f')
package() {
install -Dm755 "lf" "$pkgdir/usr/bin/lf"
diff --git a/README.md b/README.md
deleted file mode 100644
index 0b7454269e9a..000000000000
--- a/README.md
+++ /dev/null
@@ -1,97 +0,0 @@
-```
-@dmarcoux/lf
-
-AUR package for gokcehan/lf: A terminal file manager, heavily inspired by
-ranger.
-```
-
-# Introduction
-
-This repository is an
-[AUR](https://wiki.archlinux.org/index.php/Arch_User_Repository) package for
-[gokcehan/lf](https://github.com/gokcehan/lf). For any information regarding
-`lf` itself, please refer to its [repository](https://github.com/gokcehan/lf).
-This AUR package is following GitHub releases of `lf`. It doesn't follow every
-commit on the `master` branch.
-
-# Package Installation
-
-Using your favorite [AUR
-helper](https://wiki.archlinux.org/index.php/AUR_helpers), install the [lf
-AUR package](https://aur.archlinux.org/packages/lf/) like this:
-
-```bash
-$ aura -A lf
-```
-
-# Package Maintenance
-
-This section is mostly notes on how this package is maintained.
-
-## Initial Setup
-
-Whenever setting up the environment to maintain this package, these manual steps
-must be done once.
-
-### 1. Write Access to the AUR
-
-Have a look on the
-[wiki](https://wiki.archlinux.org/index.php/Arch_User_Repository#Authentication)
-if you don't already have write access to the AUR.
-
-### 2. Git Mirror
-
-The `github.com/dmarcoux/lf` repository is a mirror of the
-`aur.archlinux.org/lf` repository. Set it up by running the following
-commands:
-
-```bash
-$ git clone git+ssh://aur@aur.archlinux.org/lf.git
-$ git remote set-url origin --add git@github.com:dmarcoux/lf.git
-```
-
-## Routine Update
-
-Whenever updating this package, these steps must always be done.
-
-### 1. Generate the .SRCINFO file
-
-The tool `mksrcinfo` provided by the [AUR package
-`pkgbuild-introspection-git`](https://aur.archlinux.org/packages/pkgbuild-introspection-git)
-is really useful to generate the `.SRCINFO` file. Simply run the command in the
-repository's root directory to use it:
-
-```bash
-$ mksrcinfo
-```
-
-### 2. Generate the checksums in the PKGBUILD file
-
-The script `updpkgsums` (which comes with `pacman`'s version 4.1 or greater) is
-a simple way to generate the checksums in the `PKGBUILD` file. It is as simple
-as running the script in the repository's root directory:
-
-```bash
-$ updpkgsums
-```
-
-### 3. Validate the PKGBUILD file
-
-The script `makepkg` (which comes with `pacman`) is the usual way to validate a
-`PKGBUILD` file. With a valid `PKGBUILD` file, it will create a package; with a
-nonvalid `PKGBUILD` file, it will raise an error. Simply run the command in the
-repository's root directory to use it:
-
-```bash
-$ makepkg
-```
-
-## Automation
-
-All steps in the `Routine Update` section can be automated. To do so, I use a
-git pre-commit hook ([pre-commit.sh](pre-commit.sh)). Set it up by running the
-following command in the repository's root directory:
-
-```bash
-$ ln -s ../../pre-commit.sh .git/hooks/pre-commit
-```