summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranekos2016-05-18 16:36:25 +0900
committeranekos2016-05-18 16:36:25 +0900
commite2b62bfad457f921e1b7fb08cec732ab45ad4200 (patch)
tree287db7173117f3b90904e7263bd1b7931b101fb9
downloadaur-e2b62bfad457f921e1b7fb08cec732ab45ad4200.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..40e7d4383042
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Wed May 18 07:36:13 UTC 2016
+pkgbase = lfe-git
+ pkgdesc = Lisp Flavoured Erlang
+ pkgver = 20160518
+ pkgrel = 1
+ url = http://lfe.io/
+ arch = i686
+ arch = x86_64
+ license = Apache_v2
+ depends = erlang
+ source = lfe-git::git+https://github.com/rvirding/lfe/
+ md5sums = SKIP
+
+pkgname = lfe-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1733c8a0e710
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: anekos <anekos@snca.net>
+pkgname=lfe-git
+pkgver=20160518
+pkgrel=1
+pkgdesc="Lisp Flavoured Erlang"
+url="http://lfe.io/"
+arch=('i686' 'x86_64')
+license=('Apache_v2')
+depends=('erlang')
+source=("$pkgname::git+https://github.com/rvirding/lfe/")
+md5sums=('SKIP')
+
+package () {
+ cd $srcdir/$pkgname
+
+ make compile
+
+ mkdir -p "$pkgdir/opt/lfe"
+ cp -r * "$pkgdir/opt/lfe/"
+
+ cd "$pkgdir/opt/lfe/"
+
+ make install-man MANINSTDIR="$pkgdir/usr/share/man"
+
+ install -d -m755 "$pkgdir/usr/bin"
+
+ ln -sf /opt/lfe/bin/lfe "$pkgdir/usr/bin/"
+ ln -sf /opt/lfe/bin/lfec "$pkgdir/usr/bin/"
+ ln -sf /opt/lfe/bin/lfedoc "$pkgdir/usr/bin/"
+ ln -sf /opt/lfe/bin/lfescript "$pkgdir/usr/bin/"
+}
+
+# vim:set ts=2 sw=2 et:
+