summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-08-27 20:24:54 +0200
committerhaawda2018-08-27 20:24:54 +0200
commitfbba1b0e61835bb3afeccd6870ee6fae1e1958ce (patch)
treecd8f428c080d085214345a9b159a474df0fb4f45
parent3e23e0b2befb0264d24e3ab814f6d62eba431468 (diff)
downloadaur-fbba1b0e61835bb3afeccd6870ee6fae1e1958ce.tar.gz
adopted, small cosmetics
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD21
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2881f1e01a3d..aa0c519b0646 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = lfe-git
pkgdesc = Lisp Flavoured Erlang
- pkgver = r963.2880c8a
+ pkgver = r974.ea62f92
pkgrel = 1
url = http://lfe.io/
arch = x86_64
license = Apache_v2
- depends = erlang-nox
+ depends = erlang
+ provides = lfe
conflicts = lfe
source = git+https://github.com/rvirding/lfe.git#branch=develop
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index ab5ec222d91d..43d78b9fa0d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,22 @@
-# Maintainer: Dan Beste <dan.ray.beste@gmail.com>
+# Contributor: Dan Beste <dan.ray.beste@gmail.com>
# Contributor: anekos <anekos@snca.net>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname='lfe-git'
-_pkgname='lfe'
-pkgver=r963.2880c8a
+pkgver=r974.ea62f92
pkgrel=1
pkgdesc="Lisp Flavoured Erlang"
url='http://lfe.io/'
arch=('x86_64')
license=('Apache_v2')
-depends=('erlang-nox')
-conflicts=("${_pkgname}")
+depends=('erlang')
+conflicts=("${pkgname%-git}")
+provides=("${pkgname%-git}")
source=('git+https://github.com/rvirding/lfe.git#branch=develop')
sha256sums=('SKIP')
pkgver() {
- cd "${_pkgname}"
+ cd "${pkgname%-git}"
printf "r%s.%s" \
"$(git rev-list --count HEAD)" \
@@ -23,17 +24,17 @@ pkgver() {
}
build() {
- cd "${_pkgname}"
+ cd "${pkgname%-git}"
make
}
package () {
- cd "${_pkgname}"
+ cd "${pkgname%-git}"
make PREFIX="${pkgdir}/usr" install
- cd "${pkgdir}/usr/bin"
+ cd "${pkgdir}"/usr/bin
# Properly symlink lfe binaries:
for link in *; do
@@ -46,5 +47,3 @@ package () {
rm -rv "${pkgdir}/usr/share/man/cat7"
rm -v "${pkgdir}/usr/share/man/index.db"
}
-
-# vim:set ts=2 sw=2 et: