summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTjaart van der Walt2018-07-21 10:20:18 -0700
committerTjaart van der Walt2018-07-21 10:20:18 -0700
commit5e11313535b209dfa31a4401d9a2febec8f344a3 (patch)
treef3c9fe435bd145c7b7f5134c7a0b7f805c696601
parent357fbd6f6d0192f2e856493ae79e68834f1318ca (diff)
downloadaur-lfm-hg.tar.gz
Use lfm3 as source instead of lfm
The AUR package `lfm3` has been renamed as simply `lfm`, because development on lfm2 has ceased. To remain consistent, I have renamed `lfm3-hg` to `lfm-hg`
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD27
2 files changed, 15 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa1462a68039..395924047e35 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = lfm-hg
- pkgdesc = A powerful file manager for the UNIX console. This package downloads the latest source from version control.
- pkgver = 20150522
+ pkgdesc = A powerful file manager for the UNIX console. Written in Python 3.4+
+ pkgver = 124.2bc89aa7f534
pkgrel = 1
- url = https://bitbucket.org/inigoserna/lfm
+ url = https://bitbucket.org/inigoserna/lfm3
arch = any
license = GPL3
makedepends = mercurial
depends = ncurses>=5.0
- depends = python2>=2.6
+ depends = python>=3.4
conflicts = lfm
- source = hg+https://bitbucket.org/inigoserna/lfm
+ source = hg+https://bitbucket.org/inigoserna/lfm3
md5sums = SKIP
pkgname = lfm-hg
diff --git a/PKGBUILD b/PKGBUILD
index 030742ac05e1..285d1eb065a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,26 @@
# Maintainer: Tjaart van der walt <aur@tjaart.co.za>
-#
-# This is a modified version of the AUR package lfm, downloading the latest
-# sources from the project's official mercurial repository
-#
-# The latest released version of lfm (2.3 at the time of writing) had a blocking
-# bug for me. This bug appears to be fixed in version control, but no release
-# with this fix has been made yet.
pkgname=lfm-hg
-pkgver=20150522
+pkgver=124.2bc89aa7f534
pkgrel=1
-pkgdesc="A powerful file manager for the UNIX console. This package downloads the latest source from version control."
+pkgdesc="A powerful file manager for the UNIX console. Written in Python 3.4+"
arch=('any')
-url="https://bitbucket.org/inigoserna/lfm"
+url="https://bitbucket.org/inigoserna/lfm3"
license=('GPL3')
conflicts=('lfm')
-depends=('ncurses>=5.0' 'python2>=2.6')
+
+depends=('ncurses>=5.0' 'python>=3.4')
makedepends=('mercurial')
-source=(hg+https://bitbucket.org/inigoserna/lfm)
+source=(hg+https://bitbucket.org/inigoserna/lfm3)
md5sums=('SKIP')
build() {
- cd "$srcdir/lfm"
- sed -i '1s,env python,&2,' lfm/*
- python2 setup.py build
+ cd "$srcdir/lfm3"
+ python setup.py build
}
package() {
- cd "$srcdir/lfm"
- python2 setup.py install --prefix=/usr --root="$pkgdir"
+ cd "$srcdir/lfm3"
+ python setup.py install --prefix=/usr --root="$pkgdir"
}