summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorConnor Etherington2023-03-14 12:50:17 +0200
committerConnor Etherington2023-03-14 12:50:17 +0200
commita4e08f48eddaa0c7a774db8603e3bab6ca1759e9 (patch)
tree141da5ea83a1a53528f015a136d552c2867f2d86
parentccce1d9070c5b82d15c46dc3abe301662a9cb90b (diff)
downloadaur-a4e08f48eddaa0c7a774db8603e3bab6ca1759e9.tar.gz
Auto-Commit Update - 2023.03.14
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 13 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 72bb4c89f830..6735d6ee4dff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = lfp
pkgdesc = A wrapper for the lf file manager with in-terminal media previews, on-exit directory changing and much more
- pkgver = 3.0.1
+ pkgver = 3.1
pkgrel = 1
url = https://gitlab.com/a4to/lfp
- install = lfp.install
arch = x86_64
license = MIT
depends = lf
@@ -24,12 +23,12 @@ pkgbase = lfp
depends = python-attrs
optdepends = nodejs: to make use of lfps built in node actions manager
conflicts = lfp-git
- source = https://concise.cc/pkg/lfp-3.0.1-1-x86_64.pkg.tar.zst
- source = https://concise.cc/pkg/lfp-3.0.1-1-x86_64.pkg.tar.zst.sig
+ source = https://concise.cc/pkg/lfp-3.1-1-x86_64.pkg.tar.zst
+ source = https://concise.cc/pkg/lfp-3.1-1-x86_64.pkg.tar.zst.sig
validpgpkeys = 9A1F3F41DDA55A60331CB8DD3714CB0967D15980
- md5sums = 4b5a1327eab602e0dc19729937aaa1a2
- md5sums = 9039d510570b731b87af3e320269aae3
- sha512sums = 6b78eb18bb9dc9694955563ba0301b2823f70d18163238a93e3a4845c8133b1b1f6eb7132a465c2a6c2e32988f1aacef5b62a0a28c582a89acd91dad530b83c7
- sha512sums = aae1783b7c28e3395fd7790b6d2ed55f5a8baa77bb5857f23dbe853de5a0257b408823d861ceaabb4f03cfc41754e36404c6b38908f0c8fb5eb860a90aba24bc
+ md5sums = 7fbf0424bae92e6442dd1a79028c6ad2
+ md5sums = ef2e165b764662bea35692c9f9f9a00f
+ sha512sums = 0738045516f3b81c1e21aec474c2bee38f8b0d216c95509198db132e6928b13531dfa58be6b23222900942f790f0ebb6579c67e838b5f88395f79338ed5716be
+ sha512sums = 602d5cbf199e9ae9edab53f56bc467b78ff29b8d3788a6f7849e827beb1a9e1d449a19f8b121b83409f075edee85c3673cb3014c69d306a3d52ec980bd8b3e28
pkgname = lfp
diff --git a/PKGBUILD b/PKGBUILD
index ea78df8e3135..dfc9afe46cbb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,11 @@
# Maintainer: Connor Etherington <connor@concise.cc>
# ---
pkgname=lfp
-pkgver=3.0.1
+pkgver=3.1
pkgrel=1
pkgdesc='A wrapper for the lf file manager with in-terminal media previews, on-exit directory changing and much more'
license=('MIT')
arch=('x86_64')
-install="lfp.install"
url="https://gitlab.com/a4to/lfp"
depends=(lf zsh ffmpeg graphicsmagick openslide ghostscript bat fzf dunst dialog xsel lolcat python3 python-docopt python-pillow python-attrs)
conflicts=(lfp-git)
@@ -18,26 +17,16 @@ source=(
"https://concise.cc/pkg/${pkgname}-${pkgver}-${pkgrel}-$arch.pkg.tar.zst.sig"
)
sha512sums=(
- '6b78eb18bb9dc9694955563ba0301b2823f70d18163238a93e3a4845c8133b1b1f6eb7132a465c2a6c2e32988f1aacef5b62a0a28c582a89acd91dad530b83c7'
- 'aae1783b7c28e3395fd7790b6d2ed55f5a8baa77bb5857f23dbe853de5a0257b408823d861ceaabb4f03cfc41754e36404c6b38908f0c8fb5eb860a90aba24bc'
+ '0738045516f3b81c1e21aec474c2bee38f8b0d216c95509198db132e6928b13531dfa58be6b23222900942f790f0ebb6579c67e838b5f88395f79338ed5716be'
+ '602d5cbf199e9ae9edab53f56bc467b78ff29b8d3788a6f7849e827beb1a9e1d449a19f8b121b83409f075edee85c3673cb3014c69d306a3d52ec980bd8b3e28'
)
md5sums=(
- '4b5a1327eab602e0dc19729937aaa1a2'
- '9039d510570b731b87af3e320269aae3'
+ '7fbf0424bae92e6442dd1a79028c6ad2'
+ 'ef2e165b764662bea35692c9f9f9a00f'
)
validpgpkeys=('9A1F3F41DDA55A60331CB8DD3714CB0967D15980')
package() {
-
- cd "$srcdir/$pkgname/lfpreviewer"
- python3 setup.py install --root="$pkgdir" --optimize=1
-
cd "$srcdir/$pkgname"
- install -Dm755 usr/bin/* -t "${pkgdir}/usr/bin"
- install -Dm755 usr/share/${pkgname}/{lfp,lfpcd,cleaner,scope} -t "${pkgdir}/usr/share/${pkgname}"
- install -Dm644 usr/share/${pkgname}/{lfp-icons,lfprc} -t "${pkgdir}/usr/share/${pkgname}"
- install -Dm644 usr/share/licenses/${pkgname}/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm644 usr/share/doc/${pkgname}/README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
- install -Dm644 usr/share/man/man1/${pkgname}.1.gz "${pkgdir}/usr/share/man/man1/${pkgname}.1.gz"
-
+ make clean install
}