summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorConnor Etherington2023-12-03 00:35:17 +0200
committerConnor Etherington2023-12-03 00:35:17 +0200
commitb42f8adb5d3db8d2a22158d741bd828d50f97c1b (patch)
tree485132fa0679eb68b16393a45b372866cc25827f
parente4c137cbf1bf1c75d1edc6a082813ca02c1d3382 (diff)
downloadaur-b42f8adb5d3db8d2a22158d741bd828d50f97c1b.tar.gz
Auto-Commit Update - 2023.12.03
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e441649c61d4..f02af0a579fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lfp
pkgdesc = A wrapper for the lf file manager with in-terminal media previews, on-exit directory changing and much more
- pkgver = 4.1.2
+ pkgver = 4.1.3
pkgrel = 1
url = https://gitlab.com/a4to/lfp
install = lfp.install
@@ -24,12 +24,13 @@ pkgbase = lfp
depends = python-attrs
depends = libxres
depends = python-setuptools
+ depends = python-pip
optdepends = nodejs: to make use of lfps built in node actions manager
optdepends = python3: to make use of lfps built in python actions manager
conflicts = lfp-git
- source = https://software.concise.cc/x86_64/lfp-4.1.2-1-x86_64.pkg.tar.xz
+ source = https://software.concise.cc/x86_64/lfp-4.1.3-1-x86_64.pkg.tar.xz
validpgpkeys = 81BACEEBC3EA26E127166E4A819BB92A9A48160E
- md5sums = a552a2f2dd05a12787b08823b193c533
- sha512sums = 9da562aaa90c2b81149bb0e594f3b47c2b380f4b7da144393e17640748c61b9e50ec5fc7948c14611a8df9f58a1ccfefdfe8b4f4c579bc28fa9e694444d63158
+ md5sums = 0ebf2d0e1c065cd984d6b540498aecda
+ sha512sums = 835ad2c0f4e50cc6160c0c1ccb46d54067380e259751db7dd1cc249eaf814ee532f261bfee263f77c7e5f48d6df8e37c1edacf5ef2186a5fcbc1ecef264c9503
pkgname = lfp
diff --git a/PKGBUILD b/PKGBUILD
index be5b5deb624c..2f70ec4884f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Connor Etherington <connor@concise.cc>
# ---
pkgname=lfp
-pkgver=4.1.2
+pkgver=4.1.3
pkgrel=1
pkgdesc='A wrapper for the lf file manager with in-terminal media previews, on-exit directory changing and much more'
license=('MIT')
arch=('x86_64')
install="lfp.install"
url="https://gitlab.com/a4to/lfp"
-depends=(lf zsh ffmpeg graphicsmagick openslide ghostscript bat fzf dunst dialog xsel lolcat python3 python-docopt python-pillow python-attrs libxres python-setuptools)
+depends=(lf zsh ffmpeg graphicsmagick openslide ghostscript bat fzf dunst dialog xsel lolcat python3 python-docopt python-pillow python-attrs libxres python-setuptools python-pip)
conflicts=(lfp-git)
optdepends=(
'nodejs: to make use of lfps built in node actions manager'
@@ -18,10 +18,10 @@ source=(
"https://software.concise.cc/x86_64/${pkgname}-${pkgver}-${pkgrel}-$arch.pkg.tar.xz"
)
sha512sums=(
- '9da562aaa90c2b81149bb0e594f3b47c2b380f4b7da144393e17640748c61b9e50ec5fc7948c14611a8df9f58a1ccfefdfe8b4f4c579bc28fa9e694444d63158'
+ '835ad2c0f4e50cc6160c0c1ccb46d54067380e259751db7dd1cc249eaf814ee532f261bfee263f77c7e5f48d6df8e37c1edacf5ef2186a5fcbc1ecef264c9503'
)
md5sums=(
- 'a552a2f2dd05a12787b08823b193c533'
+ '0ebf2d0e1c065cd984d6b540498aecda'
)
validpgpkeys=(
'81BACEEBC3EA26E127166E4A819BB92A9A48160E'
@@ -32,8 +32,7 @@ package() {
cd "$srcdir/${pkgname}-${pkgver}-${pkgrel}-${arch}/lfpreviewer" ||
cd "$srcdir/${pkgname}/lfpreviewer"
- pip3 install --user --upgrade --force-reinstall --no-deps setuptools wheel
- python3 ./setup.py install --root="$pkgdir" --prefix=/usr --optimize=1
+ pip install . --root="$pkgdir" --prefix=/usr --no-deps
cd "$srcdir/${pkgname}-${pkgver}-${pkgrel}-${arch}" >/dev/null 2>&1 ||
cd "$srcdir/${pkgname}"