summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororhun2020-10-16 22:02:16 +0300
committerorhun2020-10-16 22:02:16 +0300
commit4cd6d8abd3d7eab99968245e1f8c44d362482aaa (patch)
tree469a5bc17885db732ad3769de21983f70acf8cf6
downloadaur-4cd6d8abd3d7eab99968245e1f8c44d362482aaa.tar.gz
Initial upload: lfs 0.5.1-1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0dd6264ce3a9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = lfs
+ pkgdesc = Get information on your mounted disks
+ pkgver = 0.5.1
+ pkgrel = 1
+ url = https://github.com/Canop/lfs
+ arch = x86_64
+ license = MIT
+ makedepends = cargo
+ source = lfs-0.5.1.tar.gz::https://github.com/Canop/lfs/archive/v0.5.1.tar.gz
+ sha512sums = fb533af87ead557fb8fa6dedd028e9663f7e099fd6887f4ba7026347182be7b1aa0d8a7bc51cc0957ad00f8544f1fbe812d97d6ec5bd1a044db4f651feda3fb8
+
+pkgname = lfs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf05d20c4c49
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: orhun <orhunparmaksiz@gmail.com>
+# https://github.com/orhun/pkgbuilds
+
+pkgname=lfs
+pkgver=0.5.1
+pkgrel=1
+pkgdesc="Get information on your mounted disks"
+arch=('x86_64')
+url="https://github.com/Canop/lfs"
+license=('MIT')
+makedepends=('cargo')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha512sums=('fb533af87ead557fb8fa6dedd028e9663f7e099fd6887f4ba7026347182be7b1aa0d8a7bc51cc0957ad00f8544f1fbe812d97d6ec5bd1a044db4f651feda3fb8')
+
+build() {
+ cd "$pkgname-$pkgver"
+ cargo build --release --locked --all-features
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm 755 "target/release/$pkgname" -t "$pkgdir/usr/bin"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+}