summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12020-08-17 23:17:27 +0800
committerChocobo12020-08-17 23:39:41 +0800
commit22db3b84288005ee72c96773772ddfe84252012f (patch)
tree3c90e2c0777a5b2c499fdfd37b534c27af47554c
downloadaur-22db3b84288005ee72c96773772ddfe84252012f.tar.gz
newpkg: lftp-git 4.9.2.r0.g586b2562-1
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD55
2 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c7e1bb8a3c8c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = lftp-git
+ pkgdesc = Sophisticated file transfer program
+ pkgver = 4.9.2.r0.g586b2562
+ pkgrel = 1
+ url = https://lftp.yar.ru/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = gperf
+ depends = expat
+ depends = gnutls
+ depends = hicolor-icon-theme
+ depends = libidn2
+ depends = readline
+ optdepends = perl
+ optdepends = sh
+ provides = lftp
+ conflicts = lftp
+ backup = etc/lftp.conf
+ source = git+https://github.com/lavv17/lftp.git
+ source = autoconf_bump.patch::https://github.com/lavv17/lftp/commit/df0b2b8e4fb3f334114651d9d7b8be5f8e738375.patch
+ sha256sums = SKIP
+ sha256sums = 3838c1964d40fec4a8738513a40e4b593c849dfc0675dd0a45467a14285a3c9c
+
+pkgname = lftp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..681504a89789
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=lftp-git
+pkgver=4.9.2.r0.g586b2562
+pkgrel=1
+pkgdesc="Sophisticated file transfer program"
+arch=('i686' 'x86_64')
+url="https://lftp.yar.ru/"
+license=('GPL3')
+depends=('expat' 'gnutls' 'hicolor-icon-theme' 'libidn2' 'readline')
+makedepends=('git' 'gperf')
+optdepends=('perl' 'sh')
+provides=('lftp')
+conflicts=('lftp')
+backup=('etc/lftp.conf')
+source=("git+https://github.com/lavv17/lftp.git"
+ "autoconf_bump.patch::https://github.com/lavv17/lftp/commit/df0b2b8e4fb3f334114651d9d7b8be5f8e738375.patch")
+sha256sums=('SKIP'
+ '3838c1964d40fec4a8738513a40e4b593c849dfc0675dd0a45467a14285a3c9c')
+
+
+prepare() {
+ cd "lftp"
+
+ patch -Np1 -i "$srcdir/autoconf_bump.patch"
+}
+
+pkgver() {
+ cd "lftp"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "lftp"
+
+ ./bootstrap
+ ./configure \
+ --prefix="/usr" \
+ --disable-static || true # ignore errors temporarily
+ make
+}
+
+check() {
+ cd "lftp"
+
+ make check
+}
+
+package() {
+ cd "lftp"
+
+ make DESTDIR="$pkgdir" install
+ rm -rf "$pkgdir/usr/lib"
+}