summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTea2016-05-19 19:40:27 +0100
committerTea2016-05-19 19:40:27 +0100
commitb1dce146256f58334bc3fbf35daa682e3cfb590d (patch)
treed8d7ed1a404baa178e5194345c520a6fba68ac96
parent81fabe90ea59659a945f2148f8b71b742465c3af (diff)
downloadaur-b1dce146256f58334bc3fbf35daa682e3cfb590d.tar.gz
fix tinyxml2 stuff, remove aria2 switch because it's crap
-rw-r--r--.SRCINFO13
-rwxr-xr-xPKGBUILD30
2 files changed, 11 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8b61b32eef4d..922a73f5afb9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed May 18 20:45:12 UTC 2016
+# Thu May 19 18:36:14 UTC 2016
pkgbase = lgogdownloader-git
pkgdesc = An open source downloader for GOG.com games, uses the GOG.com API (git version)
pkgver = 2.28.r5.g730c1ff
- pkgrel = 2
+ pkgrel = 3
url = http://www.gog.com/en/forum/general/lgogdownloader_gogdownloader_for_linux
arch = i686
arch = x86_64
@@ -11,8 +11,13 @@ pkgbase = lgogdownloader-git
makedepends = help2man
makedepends = cmake
makedepends = git
- depends = boost>=1.6.0-5
- depends = curl
+ depends = boost
+ depends = boost-libs
+ depends = jsoncpp
+ depends = liboauth
+ depends = rhash
+ depends = htmlcxx
+ depends = tinyxml2
provides = lgogdownloader
conflicts = lgogdownloader
source = git://github.com/Sude-/lgogdownloader.git
diff --git a/PKGBUILD b/PKGBUILD
index fc8aabf65e07..ba4ac5d848a9 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=lgogdownloader-git
pkgver=2.28.r5.g730c1ff
-pkgrel=2
+pkgrel=3
pkgdesc="An open source downloader for GOG.com games, uses the GOG.com API (git version)"
url="http://www.gog.com/en/forum/general/lgogdownloader_gogdownloader_for_linux"
arch=(i686 x86_64)
license=(WTFPL)
-depends=('boost>=1.6.0-5' 'boost-libs=>1.6.0-5' 'jsoncpp' 'liboauth' 'rhash' 'tinyxml2' 'htmlcxx')
+depends=('boost' 'boost-libs' 'jsoncpp' 'liboauth' 'rhash' 'htmlcxx' 'tinyxml2')
makedepends=('help2man' 'cmake' 'git')
provides=('lgogdownloader')
conflicts=('lgogdownloader')
@@ -15,32 +15,6 @@ _gitname="lgogdownloader"
source=('git://github.com/Sude-/lgogdownloader.git')
sha256sums=('SKIP')
-# lgogdownloader has a new experimental aria2 feature available
-# set _aria2 to "yes" to enable it
-# For more details see https://www.gog.com/forum/general/lgogdownloader_gogdownloader_for_linux/post744
-# Your mileage may vary -- It probably doesn't work
-_aria2="no"
-
-if [ "$_aria2" == "no" ]; then
-
- depends=("$depends" 'curl')
-
-elif [ "$_aria2" == "yes" ]; then
- depends=("$depends" 'aria2')
-
- source=(
- "$source"
- 'https://sites.google.com/site/gogdownloader/use_aria2.diff'
- )
- sha256sums=(
- 'SKIP'
- '539748573dfde781d29a1fed6bf7f0815353d8e93f1988a73ef9cd13459720ff'
- )
-else
- error "$_aria2: Invalid option for _aria2 switch in PKGBUILD. Expected 'yes' or 'no'."
- return 1
-fi
-
pkgver() {
cd $srcdir/${_gitname}
git describe --long | sed 's/^v//;s/-/.r/;s/-/./'