summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2020-12-06 23:17:29 +0100
committerFabioLolix2020-12-06 23:17:29 +0100
commitf3a6e1fdea0dc12759867ee33c37968ab98ba0a8 (patch)
treef25fe7a181c654c9ee68aa19ac31411ddde2560b
parent7c6f71c35a0bca9ecf4e0945259c4bab5628cd0d (diff)
downloadaur-f3a6e1fdea0dc12759867ee33c37968ab98ba0a8.tar.gz
revision
-rw-r--r--.AURINFO22
-rw-r--r--.SRCINFO25
-rwxr-xr-xPKGBUILD59
3 files changed, 38 insertions, 68 deletions
diff --git a/.AURINFO b/.AURINFO
deleted file mode 100644
index 3f61297af7c3..000000000000
--- a/.AURINFO
+++ /dev/null
@@ -1,22 +0,0 @@
-pkgbase = lgogdownloader-git
- pkgdesc = An open source downloader for GOG.com games, uses the GOG.com API (git version)
- pkgver = 20140830
- pkgrel = 1
- url = http://www.gog.com/en/forum/general/lgogdownloader_gogdownloader_for_linux
- arch = i686
- arch = x86_64
- license = WTFPL
- makedepends = help2man
- depends = boost
- depends = jsoncpp
- depends = liboauth
- depends = rhash
- depends = tinyxml
- depends = htmlcxx
- depends = curl
- provides = lgogdownloader
- conflicts = lgogdownloader
- source = git://github.com/Sude-/lgogdownloader.git
-
-pkgname = lgogdownloader-git
-
diff --git a/.SRCINFO b/.SRCINFO
index 35e6e4f89f21..00c86714c026 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,25 @@
-# Generated by mksrcinfo v8
-# Tue Dec 27 01:44:52 UTC 2016
pkgbase = lgogdownloader-git
- pkgdesc = An open source downloader for GOG.com games, uses the GOG.com API (git version)
- pkgver = 3.0.r7.ge045612
+ pkgdesc = Open source downloader for GOG.com games, uses the GOG.com API
+ pkgver = 3.7.r13.g5c64fc3
pkgrel = 2
- url = http://www.gog.com/en/forum/general/lgogdownloader_gogdownloader_for_linux
- arch = i686
+ url = https://sites.google.com/site/gogdownloader/
arch = x86_64
- license = WTFPL
+ arch = i686
+ arch = pentium4
+ license = custom:WTFPL
+ makedepends = git
makedepends = help2man
makedepends = cmake
- makedepends = git
- depends = boost
+ makedepends = boost
depends = boost-libs
depends = jsoncpp
- depends = liboauth
+ depends = tinyxml2
depends = rhash
depends = htmlcxx
- depends = tinyxml2
- provides = lgogdownloader=$_releasever
+ depends = qt5-webengine
+ provides = lgogdownloader
conflicts = lgogdownloader
- source = git://github.com/Sude-/lgogdownloader.git
+ source = git+https://github.com/Sude-/lgogdownloader.git
sha256sums = SKIP
pkgname = lgogdownloader-git
diff --git a/PKGBUILD b/PKGBUILD
index b62812f561f0..8a82edac6a00 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,42 @@
-# Maintainer: Joe Davison <joe@warhaggis.com>
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Joe Davison <joe@warhaggis.com>
pkgname=lgogdownloader-git
-pkgver=3.0.r7.ge045612
+pkgver=3.7.r13.g5c64fc3
pkgrel=2
-pkgdesc="An open source downloader for GOG.com games, uses the GOG.com API (git version)"
-url="http://www.gog.com/en/forum/general/lgogdownloader_gogdownloader_for_linux"
-arch=(i686 x86_64)
-license=(WTFPL)
-depends=('boost' 'boost-libs' 'jsoncpp' 'liboauth' 'rhash' 'htmlcxx' 'tinyxml2')
-makedepends=('help2man' 'cmake' 'git')
-_releasever=`echo $pkgver | sed 's/\.r.*//'`
-provides=('lgogdownloader=$_releasever')
-conflicts=('lgogdownloader')
-_gitname="lgogdownloader"
-source=('git://github.com/Sude-/lgogdownloader.git')
+pkgdesc="Open source downloader for GOG.com games, uses the GOG.com API"
+url="https://sites.google.com/site/gogdownloader/"
+arch=(x86_64 i686 pentium4)
+license=('custom:WTFPL')
+depends=(boost-libs jsoncpp tinyxml2 rhash htmlcxx qt5-webengine)
+makedepends=(git help2man cmake boost)
+provides=(lgogdownloader)
+conflicts=(lgogdownloader)
+source=("git+https://github.com/Sude-/lgogdownloader.git")
sha256sums=('SKIP')
pkgver() {
- cd $srcdir/${_gitname}
- git describe --long | sed 's/^v//;s/-/.r/;s/-/./'
+ cd "${pkgname%-git}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd $srcdir/${_gitname}
-
- if [ ! -d "build" ]; then
- mkdir build
- else
- rm -rf build/*
- fi
-
-# Possible options for -DCMAKE_BUILD_TYPE are Release and Debug
-# Debug has console spew
- cd build
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
+ cd "${srcdir}/${pkgname%-git}"
+ [[ -d build ]] || mkdir build
}
build() {
- cd $srcdir/${_gitname}/build
-msg "$_releasever"
- make
+ cd "${srcdir}/${pkgname%-git}/build"
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DUSE_QT_GUI=ON
+
+ make
}
package() {
- cd $srcdir/${_gitname}/build
-
- make DESTDIR=$pkgdir install
+ cd "${srcdir}/${pkgname%-git}/build"
+ make DESTDIR=$pkgdir install
+ install -Dm644 ../COPYING ${pkgdir}/usr/share/licenses/${pkgname}/COPYING
}