summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-07-13 11:12:32 +0300
committerDimitris Kiziridis2020-07-13 11:12:32 +0300
commit8be9c0773f991925dbcdfc2485cce5d07f9e4275 (patch)
tree5553372151ad61fa9069b101d6fb13aab4119821
downloadaur-8be9c0773f991925dbcdfc2485cce5d07f9e4275.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD21
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..388209c941dd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = liar
+ pkgdesc = Linux Installer for Archives (liar) is an easy to use command to install, list and remove software packaged as an archive on Linux systems
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/beego/bee
+ arch = any
+ license = GPL3
+ depends = bash
+ source = liar-0.1.tar.gz::https://framagit.org/grumpyf0x48/liar/-/archive/0.1/liar-0.1.tar.gz
+ sha256sums = befe9358b85512723bf68befbc2443b068ba43c4c1af09c25a9ac4f277e04535
+
+pkgname = liar
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..46e96a761b3e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=liar
+pkgver=0.1
+pkgrel=1
+pkgdesc='Linux Installer for Archives (liar) is an easy to use command to install, list and remove software packaged as an archive on Linux systems'
+arch=('any')
+url="https://github.com/beego/bee"
+license=('GPL3')
+depends=('bash')
+source=("${pkgname}-${pkgver}.tar.gz::https://framagit.org/grumpyf0x48/liar/-/archive/${pkgver}/liar-${pkgver}.tar.gz")
+sha256sums=('befe9358b85512723bf68befbc2443b068ba43c4c1af09c25a9ac4f277e04535')
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ install -Dm644 liar-completion -t "${pkgdir}/etc/bash_completion.d"
+ install -Dm755 liar -t "${pkgdir}/usr/bin"
+ install -Dm644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dm644 CHANGELOG.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+}
+# vim:set ts=2 sw=2 et: \ No newline at end of file