summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Martens2020-02-19 22:06:51 +0100
committerThomas Martens2020-02-19 22:06:51 +0100
commit60c16759692497618a18e646509b9d358d586b8a (patch)
tree4a16969f7bd2f9a039eb61b743a66a23fc374eff
downloadaur-lib1541img.tar.gz
PKBUILD v1.1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD46
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3cd329ef8a31
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by makepkg 5.2.1
+# Wed Feb 19 21:02:41 UTC 2020
+pkgbase = lib1541img
+ pkgdesc = Library (incl. headers) for handling Commodore 1541 disk images.
+ pkgver = 1.1
+ pkgrel = 1
+ url = https://github.com/excess-c64/lib1541img
+ arch = i686
+ arch = x86_64
+ license = custom:BSD 2-Clause "Simplified" License
+ makedepends = git
+ depends = glibc
+ source = git+https://github.com/excess-c64/lib1541img.git#tag=v1.1
+ md5sums = SKIP
+
+pkgname = lib1541img
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..925920a7c190
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Thomas Martens <aur@defaultschuldiger.de>
+pkgname=lib1541img
+pkgver=1.1
+pkgrel=1
+epoch=
+pkgdesc="Library (incl. headers) for handling Commodore 1541 disk images."
+arch=('i686' 'x86_64')
+url="https://github.com/excess-c64/${pkgname}"
+license=('custom:BSD 2-Clause "Simplified" License')
+groups=()
+depends=('glibc')
+makedepends=('git')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+https://github.com/excess-c64/${pkgname}.git#tag=v${pkgver}")
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+prepare() {
+ cd "$pkgname"
+ git submodule update --init
+}
+
+build() {
+ cd "$pkgname"
+ make -j4 strip
+}
+
+package() {
+ cd "$pkgname"
+ make prefix="/usr/" DESTDIR="$pkgdir/" install
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}