summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorqeeg2020-09-10 17:17:03 -0500
committerqeeg2020-09-10 17:17:03 -0500
commitb186e6866921b5e784eb02bd9bae3b6db5a7f011 (patch)
treec9e693632880e09e51ce0de69f439a6cf7a44746
downloadaur-b186e6866921b5e784eb02bd9bae3b6db5a7f011.tar.gz
First AUR build for 86Box
-rw-r--r--.SRCINFO21
-rw-r--r--86box.desktop11
-rw-r--r--86box.sh21
-rw-r--r--PKGBUILD50
4 files changed, 103 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..125db76fb8c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = lib32-86box-nightly-bin
+ pkgdesc = x86 full-system emulator running via Wine
+ pkgver = 3.0.git
+ pkgrel = 0
+ url = http://86box.net
+ arch = x86_64
+ license = GPL2
+ depends = wine
+ depends = winetricks
+ provides = 86box
+ conflicts = 86box
+ options = !strip
+ source = 86box.desktop
+ source = 86box.sh
+ source = https://ci.86box.net/job/86Box/lastSuccessfulBuild/artifact/*zip*/archive.zip
+ md5sums = 91806130ae51196094ec77f2a7b4ce3e
+ md5sums = de15a6b671ebd6add47119b3268ae75b
+ md5sums = 98e90dc4e6562bb4060f463bc42ebd6e
+
+pkgname = lib32-86box-nightly-bin
+
diff --git a/86box.desktop b/86box.desktop
new file mode 100644
index 000000000000..957457b52f7f
--- /dev/null
+++ b/86box.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=3.0.git
+Type=Application
+Name=86Box
+Comment=x86 PC emulator
+Exec=/usr/bin/86box.sh
+Encoding=UTF-8
+Categories=Game;
+Terminal=false
+StartupNotify=true
+StartupWMClass=86Box.exe \ No newline at end of file
diff --git a/86box.sh b/86box.sh
new file mode 100644
index 000000000000..8e2e1af12631
--- /dev/null
+++ b/86box.sh
@@ -0,0 +1,21 @@
+#!/bin/bash
+export WINEPREFIX="$HOME/.86box/wine"
+
+if [ ! -d "$HOME"/.86box ] ; then
+ mkdir -p "$HOME"/.86box/wine || exit 1
+ ln -s /usr/share/86box/86Box.exe "$HOME"/.86box/86Box.exe || exit 1
+ ln -s /usr/share/86box/discord_game_sdk.dll "$HOME"/.86box/discord_game_sdk.dll || exit 1
+ ln -s /usr/share/86box/freetype.dll "$HOME"/.86box/freetype.dll || exit 1
+ ln -s /usr/share/86box/gsdll32.dll "$HOME"/.86box/gsdll32.dll || exit 1
+ ln -s /usr/share/86box/libfluidsynth.dll "$HOME"/.86box/libfluidsynth.dll || exit 1
+fi
+
+if [ ! -f "$HOME"/.cemu/wine/drive_c/windows/syswow64/vcruntime140.dll ]; then
+ if [ -n "`whereis zenity|grep bin`" ]; then
+ zenity --info --title '86Box' --text 'Installing wine dependencies.\n\nThe process may take a few minutes'
+ fi
+ winetricks -q vcrun2017
+ winetricks settings win7
+fi
+cd ~/.86box
+wine 86Box.exe "$@"
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..669386b6a5eb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: qeeg <mszoopers@protonmail.com>
+
+pkgname=lib32-86box-nightly-bin
+pkgver=3.0.git
+pkgrel=0
+pkgdesc="x86 full-system emulator running via Wine"
+arch=('x86_64')
+url="http://86box.net"
+license=('GPL2')
+depends=('wine' 'winetricks')
+source=(
+ 86box.desktop
+ 86box.sh
+ https://ci.86box.net/job/86Box/lastSuccessfulBuild/artifact/*zip*/archive.zip
+)
+provides=("86box")
+conflicts=("86box")
+
+options=(!strip)
+
+build() {
+ cd $srcdir/
+ cd archive
+ bsdtar -x -f 86Box-32-*.zip
+}
+
+package() {
+ cd $srcdir/archive
+ install -d -m755 $pkgdir/usr/share/86box
+ install -m755 86Box.exe $pkgdir/usr/share/86box
+ install -m644 discord_game_sdk.dll $pkgdir/usr/share/86box
+ install -m644 freetype.dll $pkgdir/usr/share/86box
+ install -m644 gsdll32.dll $pkgdir/usr/share/86box
+ install -m644 libfluidsynth.dll $pkgdir/usr/share/86box
+ install -d -m755 $pkgdir/usr/bin
+ cd ..
+ install -m755 86box.sh $pkgdir/usr/bin
+ install -d -m755 $pkgdir/usr/share/applications
+ install -m644 86box.desktop $pkgdir/usr/share/applications
+ find $pkgdir/usr/share/86box/ -type f -exec chmod 644 {} \;
+ find $pkgdir/usr/share/86box/ -type f -exec chmod 755 {} \;
+}
+
+post_install() {
+ echo "You will need to download an 86Box romset yourself. This is available at https://github.com/86Box/roms"
+}
+
+md5sums=('91806130ae51196094ec77f2a7b4ce3e'
+'de15a6b671ebd6add47119b3268ae75b'
+'98e90dc4e6562bb4060f463bc42ebd6e') \ No newline at end of file