summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordonGR2015-07-23 16:36:31 +0300
committerGordonGR2015-07-23 16:36:31 +0300
commitddd8929bea73eb897ba1637645c58e06ab3bfc8f (patch)
tree5c422775039ecff8142377b0c24485fa57541582
downloadaur-ddd8929bea73eb897ba1637645c58e06ab3bfc8f.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD42
-rw-r--r--a52dec-0.7.4-build.patch27
-rw-r--r--a52dec-0.7.4.tar.gzbin0 -> 241507 bytes
4 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5e2e39a4fb4a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = lib32-a52dec
+ pkgdesc = A free library for decoding ATSC A/52 streams
+ pkgver = 0.7.4
+ pkgrel = 7
+ url = http://liba52.sourceforge.net/
+ arch = x86_64
+ license = GPL2
+ makedepends = gcc-multilib
+ depends = lib32-glibc
+ depends = a52dec
+ options = !libtool
+ source = http://liba52.sourceforge.net/files/a52dec-0.7.4.tar.gz
+ source = a52dec-0.7.4-build.patch
+ md5sums = caa9f5bc44232dc8aeea773fea56be80
+ md5sums = fa16f224a7dceb7613824380abef0052
+
+pkgname = lib32-a52dec
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4ad314623254
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: GordonGR <ntheo1979@gmail.com>
+# Contributor: Thomas Baechler <thomas@archlinux.org>
+# Contributor: Sarah Hay <sarahhay@mb.sympatico.ca>
+
+_pkgname=a52dec
+pkgname=lib32-a52dec
+pkgver=0.7.4
+pkgrel=7
+pkgdesc="A free library for decoding ATSC A/52 streams"
+url="http://liba52.sourceforge.net/"
+arch=('x86_64')
+license=('GPL2')
+depends=('lib32-glibc' $_pkgname)
+makedepends=('gcc-multilib')
+options=(!libtool)
+source=("http://liba52.sourceforge.net/files/${_pkgname}-${pkgver}.tar.gz"
+ 'a52dec-0.7.4-build.patch')
+md5sums=('caa9f5bc44232dc8aeea773fea56be80'
+ 'fa16f224a7dceb7613824380abef0052')
+
+prepare() {
+cd "${srcdir}/${_pkgname}-${pkgver}"
+patch -Np1 -i "${srcdir}/a52dec-0.7.4-build.patch"
+sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' configure.in
+mv configure.in configure.ac
+./bootstrap
+}
+
+build() {
+export CC="gcc -m32"
+export CXX="g++ -m32"
+
+cd ${_pkgname}-${pkgver}
+./configure --prefix=/usr --libdir=/usr/lib32 --enable-shared
+make
+}
+
+package() {
+cd ${_pkgname}-${pkgver}
+make DESTDIR="${pkgdir}" install
+rm -rf "${pkgdir}"/usr/{include,bin,share}
+}
diff --git a/a52dec-0.7.4-build.patch b/a52dec-0.7.4-build.patch
new file mode 100644
index 000000000000..f3a29f303ceb
--- /dev/null
+++ b/a52dec-0.7.4-build.patch
@@ -0,0 +1,27 @@
+diff -Naur a52dec-0.7.4.orig/liba52/Makefile.am a52dec-0.7.4/liba52/Makefile.am
+--- a52dec-0.7.4.orig/liba52/Makefile.am 2002-01-27 20:36:48.000000000 -0800
++++ a52dec-0.7.4/liba52/Makefile.am 2004-11-05 01:10:21.317401872 -0800
+@@ -1,4 +1,3 @@
+-CFLAGS = @CFLAGS@ @LIBA52_CFLAGS@
+
+ lib_LTLIBRARIES = liba52.la
+
+diff -Naur a52dec-0.7.4.orig/liba52/configure.incl a52dec-0.7.4/liba52/configure.incl
+--- a52dec-0.7.4.orig/liba52/configure.incl 2002-01-27 20:36:48.000000000 -0800
++++ a52dec-0.7.4/liba52/configure.incl 2004-11-05 01:11:38.172672216 -0800
+@@ -2,7 +2,6 @@
+ AC_SUBST([LIBA52_LIBS])
+
+ dnl avoid -fPIC when possible
+-LIBA52_CFLAGS="$LIBA52_CFLAGS -prefer-non-pic"
+
+ AC_ARG_ENABLE([double],
+ [ --enable-double use double-precision samples])
+diff -Naur a52dec-0.7.4.orig/src/Makefile.am a52dec-0.7.4/src/Makefile.am
+--- a52dec-0.7.4.orig/src/Makefile.am 2002-06-22 18:51:57.000000000 -0700
++++ a52dec-0.7.4/src/Makefile.am 2004-11-05 01:10:21.320401375 -0800
+@@ -1,4 +1,3 @@
+-CFLAGS = @A52DEC_CFLAGS@
+
+ bin_PROGRAMS = a52dec extract_a52
+ a52dec_SOURCES = a52dec.c getopt.c gettimeofday.c
diff --git a/a52dec-0.7.4.tar.gz b/a52dec-0.7.4.tar.gz
new file mode 100644
index 000000000000..5c7c94a8faa6
--- /dev/null
+++ b/a52dec-0.7.4.tar.gz
Binary files differ