summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhuki2020-05-23 13:56:19 +0530
committerhuki2020-05-23 13:56:55 +0530
commit541192f94f4e9109caba06bd374df009a2a9856c (patch)
tree9c34632ffc5ee7a406cba21e845383ba49d3c4f0
parent66aea8bdb54d3c73be2ccf0436a7e9353a90fc63 (diff)
downloadaur-541192f94f4e9109caba06bd374df009a2a9856c.tar.gz
alure 1.2-6
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 79868eaed77b..e252ca4f0419 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = lib32-alure
pkgdesc = Utility library to help manage common tasks with OpenAL applications (32-bit)
pkgver = 1.2
- pkgrel = 5
- url = http://kcat.strangesoft.net/alure.html
+ pkgrel = 6
+ url = https://kcat.strangesoft.net/alure.html
arch = x86_64
license = MIT
makedepends = cmake
@@ -18,7 +18,7 @@ pkgbase = lib32-alure
optdepends = lib32-flac: for FLAC support
optdepends = lib32-mpg123: for MPEG support
optdepends = lib32-fluidsynth: for SoundFont 2 support
- source = http://kcat.strangesoft.net/alure-releases/alure-1.2.tar.bz2
+ source = https://kcat.strangesoft.net/alure-releases/alure-1.2.tar.bz2
source = build.patch
md5sums = 3088aba074ad02d95ea51e705053b9f5
md5sums = 6a8dfd62ccae920d393b4202736aba46
diff --git a/PKGBUILD b/PKGBUILD
index 018980be7dae..40d81e7cc343 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,10 +5,10 @@
pkgname=lib32-alure
_pkgbasename=alure
pkgver=1.2
-pkgrel=5
+pkgrel=6
pkgdesc='Utility library to help manage common tasks with OpenAL applications (32-bit)'
arch=('x86_64')
-url='http://kcat.strangesoft.net/alure.html'
+url='https://kcat.strangesoft.net/alure.html'
license=('MIT')
depends=('lib32-openal' $_pkgbasename)
makedepends=('cmake' 'lib32-libsndfile' 'lib32-libvorbis' 'lib32-flac'
@@ -18,7 +18,7 @@ optdepends=('lib32-libsndfile: for uncompressed audio support'
'lib32-flac: for FLAC support'
'lib32-mpg123: for MPEG support'
'lib32-fluidsynth: for SoundFont 2 support')
-source=("http://kcat.strangesoft.net/alure-releases/${_pkgbasename}-${pkgver}.tar.bz2"
+source=("https://kcat.strangesoft.net/alure-releases/${_pkgbasename}-${pkgver}.tar.bz2"
build.patch)
md5sums=('3088aba074ad02d95ea51e705053b9f5'
'6a8dfd62ccae920d393b4202736aba46')
@@ -34,6 +34,10 @@ build() {
export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
cd "${srcdir}/${_pkgbasename}-${pkgver}"
+
+ # workaround for recent gcc build issue
+ CXXFLAGS="$CXXFLAGS -fpermissive"
+
cmake . -DCMAKE_INSTALL_PREFIX=/usr -DLIB_SUFFIX=32 -DDUMB=OFF
make
}