summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhuki2018-10-05 23:46:49 +0530
committerhuki2018-10-05 23:46:49 +0530
commit66aea8bdb54d3c73be2ccf0436a7e9353a90fc63 (patch)
tree163ea49154c71c8a360a1e5aa8eae1a2340460d5
downloadaur-66aea8bdb54d3c73be2ccf0436a7e9353a90fc63.tar.gz
initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD49
-rw-r--r--build.patch12
3 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..79868eaed77b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = lib32-alure
+ pkgdesc = Utility library to help manage common tasks with OpenAL applications (32-bit)
+ pkgver = 1.2
+ pkgrel = 5
+ url = http://kcat.strangesoft.net/alure.html
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ makedepends = lib32-libsndfile
+ makedepends = lib32-libvorbis
+ makedepends = lib32-flac
+ makedepends = lib32-mpg123
+ makedepends = lib32-fluidsynth
+ depends = lib32-openal
+ depends = alure
+ optdepends = lib32-libsndfile: for uncompressed audio support
+ optdepends = lib32-libvorbis: for OGG Vorbis support
+ optdepends = lib32-flac: for FLAC support
+ optdepends = lib32-mpg123: for MPEG support
+ optdepends = lib32-fluidsynth: for SoundFont 2 support
+ source = http://kcat.strangesoft.net/alure-releases/alure-1.2.tar.bz2
+ source = build.patch
+ md5sums = 3088aba074ad02d95ea51e705053b9f5
+ md5sums = 6a8dfd62ccae920d393b4202736aba46
+
+pkgname = lib32-alure
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..018980be7dae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Huki <gk7huki@gmail.com>
+# Contributor: Lukas Fleischer <lfleischer@archlinux.org>
+# Contributor: Markus Martin <markus@archwyrm.net>
+
+pkgname=lib32-alure
+_pkgbasename=alure
+pkgver=1.2
+pkgrel=5
+pkgdesc='Utility library to help manage common tasks with OpenAL applications (32-bit)'
+arch=('x86_64')
+url='http://kcat.strangesoft.net/alure.html'
+license=('MIT')
+depends=('lib32-openal' $_pkgbasename)
+makedepends=('cmake' 'lib32-libsndfile' 'lib32-libvorbis' 'lib32-flac'
+ 'lib32-mpg123' 'lib32-fluidsynth')
+optdepends=('lib32-libsndfile: for uncompressed audio support'
+ 'lib32-libvorbis: for OGG Vorbis support'
+ 'lib32-flac: for FLAC support'
+ 'lib32-mpg123: for MPEG support'
+ 'lib32-fluidsynth: for SoundFont 2 support')
+source=("http://kcat.strangesoft.net/alure-releases/${_pkgbasename}-${pkgver}.tar.bz2"
+ build.patch)
+md5sums=('3088aba074ad02d95ea51e705053b9f5'
+ '6a8dfd62ccae920d393b4202736aba46')
+
+prepare() {
+ cd $_pkgbasename-$pkgver
+ patch -p1 -i ../build.patch
+}
+
+build() {
+ export CC="gcc -m32"
+ export CXX="g++ -m32"
+ export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+
+ cd "${srcdir}/${_pkgbasename}-${pkgver}"
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr -DLIB_SUFFIX=32 -DDUMB=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgbasename}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+ rm -rf "$pkgdir"/usr/{share,include,bin}
+
+ mkdir -p "$pkgdir/usr/share/licenses"
+ ln -s $_pkgbasename "$pkgdir/usr/share/licenses/$pkgname"
+}
diff --git a/build.patch b/build.patch
new file mode 100644
index 000000000000..6da41c0dd2f1
--- /dev/null
+++ b/build.patch
@@ -0,0 +1,12 @@
+diff -rupN a/src/codec_fluidsynth.cpp b/src/codec_fluidsynth.cpp
+--- a/src/codec_fluidsynth.cpp 2011-07-29 08:37:48.000000000 +0000
++++ b/src/codec_fluidsynth.cpp 2014-01-03 10:42:13.280792235 +0000
+@@ -32,7 +32,7 @@
+ #endif
+
+ #include <istream>
+-
++#include <unistd.h>
+ #include <fluidsynth.h>
+
+