summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHuki2022-05-18 20:05:18 +0530
committerHuki2022-05-18 20:05:18 +0530
commit6e54413519bb307f14e804dfa93c8e6c098e904f (patch)
tree2f99f856ae4f4667ca9762eadb32630389ebedf2
parent4eec3db097b63f11ae16a575680fb4f6bcf66d53 (diff)
downloadaur-6e54413519bb307f14e804dfa93c8e6c098e904f.tar.gz
alure 1.2-8
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD34
-rw-r--r--dumb-2.patch30
3 files changed, 56 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d2b159c6b39..23051925387f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = lib32-alure
pkgdesc = Utility library to help manage common tasks with OpenAL applications (32-bit)
pkgver = 1.2
- pkgrel = 7
- url = https://kcat.strangesoft.net/alure.html
+ pkgrel = 8
+ url = https://kcat.tomasu.net/alure.html
arch = x86_64
license = MIT
makedepends = cmake
@@ -10,6 +10,7 @@ pkgbase = lib32-alure
makedepends = lib32-libvorbis
makedepends = lib32-flac
makedepends = lib32-mpg123
+ makedepends = lib32-dumb
makedepends = lib32-fluidsynth
depends = lib32-openal
depends = alure
@@ -17,11 +18,13 @@ pkgbase = lib32-alure
optdepends = lib32-libvorbis: for OGG Vorbis support
optdepends = lib32-flac: for FLAC support
optdepends = lib32-mpg123: for MPEG support
+ optdepends = lib32-dumb: for IT, XM, S3M and MOD support
optdepends = lib32-fluidsynth: for SoundFont 2 support
- source = https://src.fedoraproject.org/lookaside/pkgs/alure/alure-1.2.tar.bz2/3088aba074ad02d95ea51e705053b9f5/alure-1.2.tar.bz2
+ source = https://kcat.tomasu.net/alure-releases/alure-1.2.tar.bz2
source = build.patch
+ source = dumb-2.patch
md5sums = 3088aba074ad02d95ea51e705053b9f5
md5sums = 6a8dfd62ccae920d393b4202736aba46
+ md5sums = f6569e1fee4015a9e0a68df37798c8aa
pkgname = lib32-alure
-
diff --git a/PKGBUILD b/PKGBUILD
index 901d9155e020..0bcb4ccf1048 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,32 +2,34 @@
# Contributor: Lukas Fleischer <lfleischer@archlinux.org>
# Contributor: Markus Martin <markus@archwyrm.net>
-_md5='3088aba074ad02d95ea51e705053b9f5'
-
pkgname=lib32-alure
_pkgbasename=alure
pkgver=1.2
-pkgrel=7
+pkgrel=8
pkgdesc='Utility library to help manage common tasks with OpenAL applications (32-bit)'
arch=('x86_64')
-url='https://kcat.strangesoft.net/alure.html'
+url='https://kcat.tomasu.net/alure.html'
license=('MIT')
depends=('lib32-openal' $_pkgbasename)
makedepends=('cmake' 'lib32-libsndfile' 'lib32-libvorbis' 'lib32-flac'
- 'lib32-mpg123' 'lib32-fluidsynth')
+ 'lib32-mpg123' 'lib32-dumb' 'lib32-fluidsynth')
optdepends=('lib32-libsndfile: for uncompressed audio support'
'lib32-libvorbis: for OGG Vorbis support'
'lib32-flac: for FLAC support'
'lib32-mpg123: for MPEG support'
+ 'lib32-dumb: for IT, XM, S3M and MOD support'
'lib32-fluidsynth: for SoundFont 2 support')
-source=("https://src.fedoraproject.org/lookaside/pkgs/alure/${_pkgbasename}-${pkgver}.tar.bz2/${_md5}/${_pkgbasename}-${pkgver}.tar.bz2"
- build.patch)
-md5sums=("${_md5}"
- '6a8dfd62ccae920d393b4202736aba46')
+source=("https://kcat.tomasu.net/alure-releases/${_pkgbasename}-${pkgver}.tar.bz2"
+ build.patch
+ dumb-2.patch)
+md5sums=('3088aba074ad02d95ea51e705053b9f5'
+ '6a8dfd62ccae920d393b4202736aba46'
+ 'f6569e1fee4015a9e0a68df37798c8aa')
prepare() {
- cd $_pkgbasename-$pkgver
+ cd ${_pkgbasename}-${pkgver}
patch -p1 -i ../build.patch
+ patch -p1 -i ../dumb-2.patch # Fix build with dumb 2 (Gentoo)
}
build() {
@@ -35,20 +37,22 @@ build() {
export CXX="g++ -m32"
export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
- cd "${srcdir}/${_pkgbasename}-${pkgver}"
+ cd ${_pkgbasename}-${pkgver}
- # workaround for recent gcc build issue
- CXXFLAGS="$CXXFLAGS -fpermissive"
+ # Workaround for recent gcc build issue
+ CXXFLAGS="$CXXFLAGS -ffat-lto-objects"
cmake . -DCMAKE_INSTALL_PREFIX=/usr -DLIB_SUFFIX=32 -DDUMB=OFF
+ # Fix build with fluidsynth 2.4
+ find -name build.make | xargs sed -e 's|\;| |g' -i
make
}
package() {
- cd "${srcdir}/${_pkgbasename}-${pkgver}"
+ cd ${_pkgbasename}-${pkgver}
make DESTDIR="${pkgdir}" install
- rm -rf "$pkgdir"/usr/{share,include,bin}
+ rm -rf "${pkgdir}"/usr/{share,include,bin}
mkdir -p "$pkgdir/usr/share/licenses"
ln -s $_pkgbasename "$pkgdir/usr/share/licenses/$pkgname"
diff --git a/dumb-2.patch b/dumb-2.patch
new file mode 100644
index 000000000000..97b8f71b7024
--- /dev/null
+++ b/dumb-2.patch
@@ -0,0 +1,30 @@
+# Already fixed upstream:
+# https://repo.or.cz/alure.git/commitdiff/9939cdfbf9c6c7a2690db7fb8dd2892389adcd5f
+
+diff -Naur a/src/codec_dumb.cpp b/src/codec_dumb.cpp
+--- a/src/codec_dumb.cpp 2011-07-29 09:37:48.000000000 +0100
++++ b/src/codec_dumb.cpp 2020-05-10 15:59:48.502632496 +0100
+@@ -272,7 +272,11 @@
+
+ private:
+ // DUMBFILE iostream callbacks
++#if DUMB_VERSION >= 2*10000
++ static int skip(void *user_data, dumb_off_t offset)
++#else
+ static int skip(void *user_data, long offset)
++#endif
+ {
+ std::istream *stream = static_cast<dumbStream*>(user_data)->fstream;
+ stream->clear();
+@@ -282,7 +286,11 @@
+ return -1;
+ }
+
++#if DUMB_VERSION >= 2*10000
++ static dumb_ssize_t read(char *ptr, size_t size, void *user_data)
++#else
+ static long read(char *ptr, long size, void *user_data)
++#endif
+ {
+ std::istream *stream = static_cast<dumbStream*>(user_data)->fstream;
+ stream->clear();