summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavorin Učakar2015-06-08 22:52:21 +0200
committerDavorin Učakar2015-06-08 22:52:21 +0200
commit751e0da83fb14205a0b56fc3ed9193d796161899 (patch)
treedc9480adce72128bc18d83f37712bc8674ba71ce
downloadaur-751e0da83fb14205a0b56fc3ed9193d796161899.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD45
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..31f04f636439
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = lib32-assimp
+ pkgdesc = Portable Open Source library to import various well-known 3D model formats in an uniform manner
+ pkgver = 3.1.1
+ pkgrel = 1
+ url = http://assimp.sourceforge.net/index.html
+ arch = x86_64
+ license = BSD
+ makedepends = cmake
+ depends = lib32-gcc-libs
+ depends = lib32-zlib
+ source = https://github.com/assimp/assimp/archive/v3.1.1.tar.gz
+ md5sums = ab9977edf95e9b2910d7cca286926e85
+
+pkgname = lib32-assimp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4a68e3b895ed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Contributor: Daniel Kirchner <daniel at ekpyron dot org>
+# Maintainer: Davorin Učakar <davorin.ucakar@gmail.com>
+
+pkgname=lib32-assimp
+_basename=assimp
+pkgver=3.1.1
+pkgrel=1
+pkgdesc="Portable Open Source library to import various well-known 3D model formats in an uniform manner"
+arch=('x86_64')
+license=('BSD')
+depends=('lib32-gcc-libs' 'lib32-zlib')
+makedepends=('cmake')
+url=('http://assimp.sourceforge.net/index.html')
+source=("https://github.com/assimp/assimp/archive/v${pkgver}.tar.gz")
+md5sums=('ab9977edf95e9b2910d7cca286926e85')
+
+build()
+{
+ cd ${srcdir}
+
+ rm -rf build && mkdir build && cd build
+
+ cmake \
+ -D ASSIMP_BUILD_ASSIMP_TOOLS=OFF \
+ -D ASSIMP_ENABLE_BOOST_WORKAROUND=ON \
+ -D ASSIMP_BUILD_SAMPLES=OFF \
+ -D CMAKE_INSTALL_PREFIX="/usr" \
+ -D CMAKE_BUILD_TYPE=Release \
+ -D CMAKE_C_FLAGS="${CFLAGS/-march=x86_64} -march=i686 -m32" \
+ -D CMAKE_CXX_FLAGS="${CXXFLAGS/-march=x86_64} -march=i686 -m32" \
+ ../${_basename}-${pkgver}
+ make
+}
+
+package()
+{
+ cd ${srcdir}/build
+
+ make DESTDIR=$pkgdir install
+ rm -rf ${pkgdir}/usr/include
+ mv ${pkgdir}/usr/lib ${pkgdir}/usr/lib32
+
+ install -Dm644 ${srcdir}/${_basename}-${pkgver}/LICENSE \
+ ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}