summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLlewelyn Trahaearn2022-01-25 15:39:43 -0800
committerLlewelyn Trahaearn2022-01-25 15:39:43 -0800
commit17971458ad327a9793bc26e55b065077b94ca92c (patch)
tree05f42142d2ccf8ff3c3b4d582b0e2b3575141c80
parent4702c4f9da4a1698a644805ad459d0d2c5ae2684 (diff)
downloadaur-17971458ad327a9793bc26e55b065077b94ca92c.tar.gz
Update to 0.8+22+gfd482a7
-rw-r--r--.SRCINFO10
-rw-r--r--0001-Fix-avahi-browse-Invalid-service-type.patch27
-rw-r--r--282.patch42
-rw-r--r--PKGBUILD21
4 files changed, 93 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fadb8d00fa63..3237da7531d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lib32-avahi
pkgdesc = Service Discovery for Linux using mDNS/DNS-SD -- compatible with Bonjour (32-bit)
- pkgver = 0.8+15+ge8a3dd0
+ pkgver = 0.8+22+gfd482a7
pkgrel = 1
url = https://github.com/lathiat/avahi
arch = x86_64
@@ -23,8 +23,12 @@ pkgbase = lib32-avahi
optdepends = lib32-gtk3: gtk3 bindings
optdepends = lib32-libevent: libevent bindings
options = !emptydirs
- source = git+https://github.com/lathiat/avahi#tag=e8a3dd0d480a754318e312e6fa66fea249808187
- sha256sums = SKIP
+ source = git+https://github.com/lathiat/avahi#tag=fd482a74625b8db8547b8cfca3ee3d3c6c721423
+ source = 282.patch
+ source = 0001-Fix-avahi-browse-Invalid-service-type.patch
+ sha512sums = SKIP
+ sha512sums = 26b1e74450944f5c4385d2f5df18523cfb953e4138f6d9e81061a626453e40d8ed2dee44535cfbb547848eefb3cdca408009d5f0e0c465f144a8803db8593b46
+ sha512sums = e39c17d9a5d534784a3c7b6947da994d0ab5fa354aac5cecde6d3baaa2bb3d57f02f91cc6fb68885a4e98f44efe615b01631a4c7af752aa26f35082cfcc0ddd7
pkgname = lib32-avahi
diff --git a/0001-Fix-avahi-browse-Invalid-service-type.patch b/0001-Fix-avahi-browse-Invalid-service-type.patch
new file mode 100644
index 000000000000..8511f3b1aaff
--- /dev/null
+++ b/0001-Fix-avahi-browse-Invalid-service-type.patch
@@ -0,0 +1,27 @@
+From 6fe6c44d953edd50c32ff6ce8fec5ac811fa3b69 Mon Sep 17 00:00:00 2001
+From: Asger Hautop Drewsen <asger@princh.com>
+Date: Mon, 9 Aug 2021 14:25:08 +0200
+Subject: [PATCH] Fix avahi-browse: Invalid service type
+
+---
+ avahi-core/browse-service.c | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/avahi-core/browse-service.c b/avahi-core/browse-service.c
+index 5531360..2d3fa75 100644
+--- a/avahi-core/browse-service.c
++++ b/avahi-core/browse-service.c
+@@ -103,7 +103,9 @@ AvahiSServiceBrowser *avahi_s_service_browser_prepare(
+ AVAHI_CHECK_VALIDITY_RETURN_NULL(server, AVAHI_PROTO_VALID(protocol), AVAHI_ERR_INVALID_PROTOCOL);
+ AVAHI_CHECK_VALIDITY_RETURN_NULL(server, !domain || avahi_is_valid_domain_name(domain), AVAHI_ERR_INVALID_DOMAIN_NAME);
+ AVAHI_CHECK_VALIDITY_RETURN_NULL(server, AVAHI_FLAGS_VALID(flags, AVAHI_LOOKUP_USE_WIDE_AREA|AVAHI_LOOKUP_USE_MULTICAST), AVAHI_ERR_INVALID_FLAGS);
+- AVAHI_CHECK_VALIDITY_RETURN_NULL(server, avahi_is_valid_service_type_generic(service_type), AVAHI_ERR_INVALID_SERVICE_TYPE);
++
++ if (!avahi_is_valid_service_type_generic(service_type))
++ service_type = "_invalid._tcp";
+
+ if (!domain)
+ domain = server->domain_name;
+--
+2.32.0
+
diff --git a/282.patch b/282.patch
new file mode 100644
index 000000000000..9e38ad06cee7
--- /dev/null
+++ b/282.patch
@@ -0,0 +1,42 @@
+From bcafdcc5465091b6088532460b671f411703f90b Mon Sep 17 00:00:00 2001
+From: Simon McVittie <smcv@debian.org>
+Date: Fri, 24 Apr 2020 11:25:41 +0100
+Subject: [PATCH] avahi-discover: Don't decode unicode strings, only
+ bytestrings
+
+Unicode strings (unicode in Python 2, str or unicode in Python 3) don't
+have a decode method; only bytestrings (str or bytes in Python 2,
+bytes in Python 3) have that. Decode exactly the strings that need
+decoding.
+
+Resolves: https://github.com/lathiat/avahi/issues/275
+Signed-off-by: Simon McVittie <smcv@debian.org>
+---
+ avahi-python/avahi-discover/avahi-discover.py | 8 +++++---
+ 1 file changed, 5 insertions(+), 3 deletions(-)
+
+diff --git a/avahi-python/avahi-discover/avahi-discover.py b/avahi-python/avahi-discover/avahi-discover.py
+index 4a2b5756..fddf4a51 100755
+--- a/avahi-python/avahi-discover/avahi-discover.py
++++ b/avahi-python/avahi-discover/avahi-discover.py
+@@ -238,15 +238,17 @@ def update_label(self,interface, protocol, name, stype, domain, host, aprotocol,
+ txts+="<b>" + _("TXT") + " <i>%s</i></b> = %s\n" % (k,v)
+ else:
+ txts = "<b>" + _("TXT Data:") + "</b> <i>" + _("empty") + "</i>"
+-
+- txts = txts.decode("utf-8")
++
++ if isinstance(txts, bytes): # Python 2
++ txts = txts.decode("utf-8")
+
+ infos = "<b>" + _("Service Type:") + "</b> %s\n"
+ infos += "<b>" + _("Service Name:") + "</b> %s\n"
+ infos += "<b>" + _("Domain Name:") + "</b> %s\n"
+ infos += "<b>" + _("Interface:") + "</b> %s %s\n"
+ infos += "<b>" + _("Address:") + "</b> %s/%s:%i\n%s"
+- infos = infos.decode("utf-8")
++ if isinstance(infos, bytes): # Python 2
++ infos = infos.decode("utf-8")
+ infos = infos % (stype, name, domain, self.siocgifname(interface), self.protoname(protocol), host, address, port, txts.strip())
+ self.info_label.set_markup(infos)
+
diff --git a/PKGBUILD b/PKGBUILD
index 32b1c53808c8..f6b13bb3195a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Douglas Soares de Andrade <douglas at archlinux dot org>
pkgname=lib32-avahi
-pkgver=0.8+15+ge8a3dd0
+pkgver=0.8+22+gfd482a7
pkgrel=1
pkgdesc='Service Discovery for Linux using mDNS/DNS-SD -- compatible with Bonjour (32-bit)'
arch=('x86_64')
@@ -16,12 +16,25 @@ makedepends=('git' 'gobject-introspection' 'libevent' 'lib32-libevent'
optdepends=('lib32-gtk3: gtk3 bindings'
'lib32-libevent: libevent bindings')
options=(!emptydirs)
-_commit=e8a3dd0d480a754318e312e6fa66fea249808187 # master
-source=("git+$url#tag=$_commit")
-sha256sums=('SKIP')
+_commit=fd482a74625b8db8547b8cfca3ee3d3c6c721423 # master
+source=("git+$url#tag=$_commit"
+ 282.patch
+ 0001-Fix-avahi-browse-Invalid-service-type.patch)
+sha512sums=('SKIP'
+ '26b1e74450944f5c4385d2f5df18523cfb953e4138f6d9e81061a626453e40d8ed2dee44535cfbb547848eefb3cdca408009d5f0e0c465f144a8803db8593b46'
+ 'e39c17d9a5d534784a3c7b6947da994d0ab5fa354aac5cecde6d3baaa2bb3d57f02f91cc6fb68885a4e98f44efe615b01631a4c7af752aa26f35082cfcc0ddd7')
prepare() {
cd ${pkgname#lib32-}
+
+ # https://bugs.archlinux.org/task/68518
+ # https://github.com/lathiat/avahi/pull/282
+ git apply -3 ../282.patch
+
+ # https://bugs.archlinux.org/task/71781
+ # https://github.com/lathiat/avahi/issues/212
+ git apply -3 ../0001-Fix-avahi-browse-Invalid-service-type.patch
+
NOCONFIGURE=1 ./autogen.sh
}