summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLlewelyn Trahaearn2016-01-06 19:40:06 -0800
committerLlewelyn Trahaearn2016-01-06 19:40:06 -0800
commitfd414b3e7e2f4d181d7d9ac12b41ecbd230475c4 (patch)
treee727f57ee37089b0ec8fc73124fe4fe7be869ce9
parentf19c04aca305bbdae93dca028acf1ff6011b3713 (diff)
downloadaur-fd414b3e7e2f4d181d7d9ac12b41ecbd230475c4.tar.gz
Modified to build locally and bumped to the latest version.
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD73
2 files changed, 81 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 266602421f4e..a10e8812f0d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,36 @@
-# Generated by makepkg 4.2.1
-# Sun Mar 29 02:10:18 UTC 2015
+# Generated by mksrcinfo v8
+# Thu Jan 7 03:37:02 UTC 2016
pkgbase = lib32-avahi
- pkgdesc = A multicast/unicast DNS-SD framework
- pkgver = 0.6.31
- pkgrel = 13
- url = http://www.avahi.org/
+ pkgdesc = Multicast DNS-SD / Zeroconf Suite (32-bit)
+ pkgver = 0.6.32rc
+ pkgrel = 1
+ url = http://git.0pointer.net/avahi.git
arch = x86_64
- groups = lib32
license = LGPL
+ makedepends = git
+ makedepends = lib32-qt4
+ makedepends = pygtk
+ makedepends = mono
+ makedepends = intltool
+ makedepends = python2-dbus
+ makedepends = gtk-sharp-2
+ makedepends = gobject-introspection
+ makedepends = lib32-gtk3
+ makedepends = xmltoman
+ makedepends = python-dbus
depends = expat
depends = lib32-libdaemon
depends = lib32-glib2
- depends = lib32-dbus-core
+ depends = lib32-libdbus
depends = lib32-libcap
depends = lib32-gdbm
depends = avahi
- source = http://mirrors.kernel.org/archlinux/extra/os/i686/avahi-0.6.31-15-i686.pkg.tar.xz
- sha256sums = f3ec6c522a881d5151c02ed922b614a064ef33cdfe174e28e0912f8ac8427175
+ optdepends = lib32-gtk3: avahi-discover-standalone, bshell, bssh, bvnc
+ optdepends = lib32-gtk2: gtk2 bindings
+ optdepends = lib32-qt4: qt4 bindings
+ options = !emptydirs
+ source = git+https://github.com/heftig/avahi#commit=bc4e85846991d0efca89add631c7cd16033f0bef
+ sha256sums = SKIP
pkgname = lib32-avahi
diff --git a/PKGBUILD b/PKGBUILD
index 717851a0eebe..6488876c599c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,63 @@
-# Maintainer: Gicu GORODENCO <cyclopsihus 'at' gmail 'dot' com>
-
-# The full build fails because of some 32-bit libraries dependency which is difficult to track
-# So KISS - Keep It Simple, Stupid - just take the already compiled binaries from repository ;-)
+# Maintainer: Llewelyn Trahaearn <WoefulDerelict at GMail dot com>
pkgname=lib32-avahi
-pkgver=0.6.31
-pkgrel32=15
-pkgrel=13
-pkgdesc="A multicast/unicast DNS-SD framework"
+pkgver=0.6.32rc
+pkgrel=1
+_commit=bc4e85846991d0efca89add631c7cd16033f0bef
+pkgdesc='Multicast DNS-SD / Zeroconf Suite (32-bit)'
arch=('x86_64')
-url="http://www.avahi.org/"
-depends=('expat' 'lib32-libdaemon' 'lib32-glib2' 'lib32-dbus-core' 'lib32-libcap' 'lib32-gdbm' 'avahi')
+url='http://git.0pointer.net/avahi.git'
license=('LGPL')
-groups=lib32
-source=(http://mirrors.kernel.org/archlinux/extra/os/i686/${pkgname/lib32-/}-${pkgver}-${pkgrel32}-i686.pkg.tar.xz)
-sha256sums=('f3ec6c522a881d5151c02ed922b614a064ef33cdfe174e28e0912f8ac8427175')
+depends=('expat' 'lib32-libdaemon' 'lib32-glib2' 'lib32-libdbus' 'lib32-libcap' 'lib32-gdbm' 'avahi')
+makedepends=(git lib32-qt4 pygtk mono intltool python2-dbus gtk-sharp-2 gobject-introspection lib32-gtk3
+ xmltoman python-dbus)
+optdepends=('lib32-gtk3: avahi-discover-standalone, bshell, bssh, bvnc'
+ 'lib32-gtk2: gtk2 bindings'
+ 'lib32-qt4: qt4 bindings')
+options=(!emptydirs)
+source=("git+https://github.com/heftig/avahi#commit=$_commit")
+sha256sums=('SKIP')
-package() {
- mkdir -p ${pkgdir}/usr/lib32
- cp -rPf ${srcdir}/usr/lib/*.so* ${pkgdir}/usr/lib32
+
+prepare() {
+ cd ${pkgname#lib32-}
+ export CC='gcc -m32'
+ export CXX='g++ -m32'
+ export LDFLAGS='-m32'
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+ NOCONFIGURE=1 ./autogen.sh
}
+
+build() {
+ cd ${pkgname#lib32-}
+ export MOC_QT4=/usr/bin/moc-qt4 PYTHON=/usr/bin/python2
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --sbindir=/usr/bin \
+ --libdir=/usr/lib32 \
+ --disable-monodoc \
+ --disable-qt3 \
+ --enable-compat-libdns_sd \
+ --enable-compat-howl \
+ --with-distro=archlinux \
+ --with-avahi-priv-access-group=network \
+ --with-autoipd-user=avahi \
+ --with-autoipd-group=avahi \
+ --with-systemdsystemunitdir=/usr/lib/systemd/system
+
+ make
+}
+
+package() {
+ cd ${pkgname#lib32-}
+ make DESTDIR="${pkgdir}" install
+
+ # howl compat
+ ln -s avahi-compat-howl.pc "$pkgdir/usr/lib32/pkgconfig/howl.pc"
+
+ # Remove conflicting files.
+ rm -rf "${pkgdir}"/{etc,usr/{share,lib,include,bin,lib32/mono}}
+} \ No newline at end of file