summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBehnam Momeni2020-01-31 17:33:07 +0330
committerBehnam Momeni2020-01-31 17:33:07 +0330
commit7b017b83c7dab809fd6957fbeee8dc9fabdcb379 (patch)
tree0d977c6d7d1784179e82eb32494d04f10f81883c
downloadaur-7b017b83c7dab809fd6957fbeee8dc9fabdcb379.tar.gz
Initial commit; version 0.1.74
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD38
-rw-r--r--git-version.h6
-rwxr-xr-xpkgconf322
-rw-r--r--x86-linux-gnu18
6 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f6f8191bf9dc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Fri Jan 31 14:01:37 UTC 2020
+pkgbase = lib32-babl
+ pkgdesc = Dynamic, any to any, pixel format conversion library (32-bit)
+ pkgver = 0.1.74
+ pkgrel = 1
+ url = https://gegl.org/babl/
+ arch = x86_64
+ license = LGPL3
+ makedepends = meson
+ makedepends = gobject-introspection
+ depends = babl
+ depends = lib32-glibc
+ depends = lib32-lcms2
+ source = https://gitlab.gnome.org/GNOME/babl/-/archive/501c71495c9f4670ee066e3abe2ad6710e954084/babl-501c71495c9f4670ee066e3abe2ad6710e954084.tar.gz
+ source = git-version.h
+ source = x86-linux-gnu
+ source = pkgconf32
+ sha512sums = 4ab96906c98588601fac2593a2086a056003adb9acaf8595abdb460a4367d0f12e8107e49e5674bcbf15010e9b653c4e489add42755f77212ec7bab8e7dfb7fc
+ sha512sums = e2417d6a72c44fc5c7721870b5124c1aefea4c772ed26e7f961e358c541fa53a8716aca689c0733e4f2d4ab36926d88cf069e474beb0eb12d2a39436df669dd1
+ sha512sums = c90a2e8d8753d4474afbaa5f1def579b4fe9580904b25125e2f942fa722a6ed54340e467d2ddf60ab9d3aeeeb93f5f740502cafe9a1f52d55da3bd78baa3b5c5
+ sha512sums = f21dd90f4f9caf67854f68baddbfbfecda295cb53f0444a1c0bfb98246390ae5d48ba5a0892fecf8a7faa937ef88884743a8e4282ca98d54c0da80c5457ef066
+
+pkgname = lib32-babl
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d39050c0bf8e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+babl-*.tar.gz
+lib32-babl-*.pkg.tar.xz
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..67135916a17a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Behnam Momeni <sbmomeni [at the] gmail [dot] com>
+# Contributor: Daniel Isenmann <daniel@archlinux.org>
+
+pkgname=lib32-babl
+_pkgbase=babl
+pkgver=0.1.74
+_commit=501c71495c9f4670ee066e3abe2ad6710e954084 # tags/BABL_0_1_74^0
+pkgrel=1
+pkgdesc="Dynamic, any to any, pixel format conversion library (32-bit)"
+arch=(x86_64)
+url="https://gegl.org/babl/"
+license=('LGPL3')
+depends=('babl' 'lib32-glibc' 'lib32-lcms2')
+makedepends=(meson gobject-introspection)
+source=("https://gitlab.gnome.org/GNOME/$_pkgbase/-/archive/$_commit/$_pkgbase-$_commit.tar.gz"
+ "git-version.h"
+ "x86-linux-gnu"
+ "pkgconf32")
+sha512sums=('4ab96906c98588601fac2593a2086a056003adb9acaf8595abdb460a4367d0f12e8107e49e5674bcbf15010e9b653c4e489add42755f77212ec7bab8e7dfb7fc'
+ 'e2417d6a72c44fc5c7721870b5124c1aefea4c772ed26e7f961e358c541fa53a8716aca689c0733e4f2d4ab36926d88cf069e474beb0eb12d2a39436df669dd1'
+ 'c90a2e8d8753d4474afbaa5f1def579b4fe9580904b25125e2f942fa722a6ed54340e467d2ddf60ab9d3aeeeb93f5f740502cafe9a1f52d55da3bd78baa3b5c5'
+ 'f21dd90f4f9caf67854f68baddbfbfecda295cb53f0444a1c0bfb98246390ae5d48ba5a0892fecf8a7faa937ef88884743a8e4282ca98d54c0da80c5457ef066')
+
+prepare() {
+ cp "git-version.h" "${_pkgbase}-$_commit/babl/"
+}
+
+build() {
+ mkdir -p "build"
+ arch-meson "${_pkgbase}-$_commit" "build" --cross-file x86-linux-gnu --libdir=/usr/lib32
+ ninja -C "build"
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C "build" install
+ rm -r "$pkgdir/usr/"{share,include}
+}
+
diff --git a/git-version.h b/git-version.h
new file mode 100644
index 000000000000..ac4a105d6687
--- /dev/null
+++ b/git-version.h
@@ -0,0 +1,6 @@
+#ifndef __GIT_VERSION_H__
+#define __GIT_VERSION_H__
+
+#define BABL_GIT_VERSION "0.1.74"
+
+#endif /* __GIT_VERSION_H__ */
diff --git a/pkgconf32 b/pkgconf32
new file mode 100755
index 000000000000..3cfde433e110
--- /dev/null
+++ b/pkgconf32
@@ -0,0 +1,2 @@
+#!/usr/bin/bash
+PKG_CONFIG_LIBDIR='/usr/lib32/pkgconfig' /usr/bin/pkgconf $@
diff --git a/x86-linux-gnu b/x86-linux-gnu
new file mode 100644
index 000000000000..b07adf2fe607
--- /dev/null
+++ b/x86-linux-gnu
@@ -0,0 +1,18 @@
+[binaries]
+c = '/usr/bin/gcc'
+cpp = '/usr/bin/g++'
+ar = '/usr/bin/gcc-ar'
+strip = '/usr/bin/strip'
+pkgconfig = './pkgconf32'
+
+[properties]
+c_args = ['-m32']
+c_link_args = ['-m32']
+cpp_args = ['-m32']
+cpp_link_args = ['-m32']
+
+[host_machine]
+system = 'linux'
+cpu_family = 'x86'
+cpu = 'i686'
+endian = 'little'