summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobbert van der Helm2021-12-19 03:43:46 +0100
committerRobbert van der Helm2021-12-19 03:43:46 +0100
commit9a99ac15a57b0fa7d049b68f0e9bb664002e126d (patch)
treec4fb2437f1395d60e8476a7b2530bd8e93a06048
parentb93a71312b32cb9cc707b1f4092c1c1e22068ada (diff)
downloadaur-lib32-boost-libs.tar.gz
Update for Boost 1.78
Based on the current boost PKGBUILD: https://github.com/archlinux/svntogit-packages/blob/86ed1d86a4e2716fc1d4e8d1a36f7d2392812330/trunk/PKGBUILD
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD15
3 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 50b30de7509e..8164b251b516 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lib32-boost-libs
pkgdesc = Free peer-reviewed portable C++ source libraries - runtime libraries (32-bit)
- pkgver = 1.76.0
+ pkgver = 1.78.0
pkgrel = 1
url = http://www.boost.org
arch = x86_64
@@ -53,10 +53,11 @@ pkgbase = lib32-boost-libs
provides = libboost_wave.so
provides = libboost_wserialization.so
options = staticlibs
- source = https://boostorg.jfrog.io/artifactory/main/release/1.76.0/source/boost_1_76_0.tar.gz
+ source = https://boostorg.jfrog.io/artifactory/main/release/1.78.0/source/boost_1_78_0.tar.gz
+ source = boost-b2-fix-lib-install.patch::https://github.com/bfgroup/b2/commit/78fd284a42ca.patch
source = boost-ublas-c++20-iterator.patch::https://github.com/boostorg/ublas/commit/a31e5cffa85f.patch
- sha256sums = 7bd7ddceec1a1dfdcbdb3e609b60d01739c38390a5f956385a12f3122049f0ca
+ sha256sums = 94ced8b72956591c4775ae2207a9763d3600b30d9d7446562c552f0a14a63be7
+ sha256sums = d233b16920ad7da8bb6e02bf5fb4e429592057b4f4db28d4babf3850e837a8db
sha256sums = aa38addb40d5f44b4a8472029b475e7e6aef1c460509eb7d8edf03491dc1b5ee
pkgname = lib32-boost-libs
-
diff --git a/.gitignore b/.gitignore
index 5050f2b65bce..20b216989402 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,4 +3,5 @@ pkg/
*.tar.gz
*.pkg.tar.*
+boost-b2-fix-lib-install.patch
boost-ublas-c++20-iterator.patch
diff --git a/PKGBUILD b/PKGBUILD
index 6c350599a8dd..624cfac0b4c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: andy123 < ajs AT online DOT de >
pkgname=lib32-boost-libs
-pkgver=1.76.0
+pkgver=1.78.0
pkgrel=1
_srcname=boost_${pkgver//./_}
pkgdesc="Free peer-reviewed portable C++ source libraries - runtime libraries (32-bit)"
@@ -30,8 +30,10 @@ provides=(libboost_atomic.so libboost_chrono.so libboost_container.so
libboost_wave.so libboost_wserialization.so)
options=('staticlibs')
source=(https://boostorg.jfrog.io/artifactory/main/release/$pkgver/source/$_srcname.tar.gz
+ boost-b2-fix-lib-install.patch::https://github.com/bfgroup/b2/commit/78fd284a42ca.patch
boost-ublas-c++20-iterator.patch::https://github.com/boostorg/ublas/commit/a31e5cffa85f.patch)
-sha256sums=('7bd7ddceec1a1dfdcbdb3e609b60d01739c38390a5f956385a12f3122049f0ca'
+sha256sums=('94ced8b72956591c4775ae2207a9763d3600b30d9d7446562c552f0a14a63be7'
+ 'd233b16920ad7da8bb6e02bf5fb4e429592057b4f4db28d4babf3850e837a8db'
'aa38addb40d5f44b4a8472029b475e7e6aef1c460509eb7d8edf03491dc1b5ee')
# This version of lib32-boost-libs does not include support OpenMPI or the
@@ -39,10 +41,13 @@ sha256sums=('7bd7ddceec1a1dfdcbdb3e609b60d01739c38390a5f956385a12f3122049f0ca'
# them
prepare() {
- cd $_srcname
+ cd $_srcname
+
+ # https://github.com/bfgroup/b2/issues/104
+ patch -Np1 -d tools/build <../boost-b2-fix-lib-install.patch
- # https://github.com/boostorg/ublas/pull/97
- patch -Np2 -i ../boost-ublas-c++20-iterator.patch
+ # https://github.com/boostorg/ublas/pull/97
+ patch -Np2 -i ../boost-ublas-c++20-iterator.patch
}
build() {