summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Was2013-04-23 14:27:13 +0000
committerThomas Dziedzic2013-04-23 14:27:13 +0000
commit38ff13dcbd15f0c60011a548ebe2a263488e04d7 (patch)
treeb4f7b422bad69a7e8aef072362e8d23ae7ae7cf8
parent7eb326fd6706c0fcc690cb3515862e326e6b625d (diff)
downloadaur-38ff13dcbd15f0c60011a548ebe2a263488e04d7.tar.gz
updated on Tue Apr 23 14:27:12 UTC 2013
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD120
2 files changed, 62 insertions, 60 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c5a1708e267..5ba8acd311fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lib32-boost-libs
pkgdesc = Free peer-reviewed portable C++ source libraries - Runtime (32 bit)
pkgver = 1.53.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.boost.org
arch = x86_64
groups = lib32
diff --git a/PKGBUILD b/PKGBUILD
index 45dff84e16d3..30547edb6c6e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=lib32-boost-libs
pkgver=1.53.0
_boostver=1_53_0
-pkgrel=1
+pkgrel=2
pkgdesc="Free peer-reviewed portable C++ source libraries - Runtime (32
bit)"
arch=('x86_64')
@@ -19,72 +19,74 @@ md5sums=('57a9e2047c0f511c4dfcf00eb5eb2fbb')
sha1sums=('0e4ef26cc7780c6bbc63987ef2f29be920e2395b')
-_stagedir="${srcdir}/stagedir"
build()
{
- export CC="gcc"
- export CFLAGS="-m32"
- export CXX="g++"
- export CXXFLAGS="-m32"
- export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
-
- # set python path for bjam
- cd "${srcdir}/boost_${_boostver}/tools"
-# echo "using python : 2.7 : /usr/bin/python2 ;" >> build/v2/user-config.jam
-# echo "using python : 3.2 : /usr/bin/python3.2 : /usr/include/python3.2mu :
-# /usr/lib32 ;" >> build/v2/user-config.jam
-# echo "using mpi ;" >> build/v2/user-config.jam
-
- # build bjam
- cd "${srcdir}/boost_${_boostver}/tools/build/v2/engine"
- ./build.sh cc
-
- _bindir="bin.linuxx86"
-
- install -d "${_stagedir}"/usr/bin
- install ${_bindir}/bjam "${_stagedir}"/usr/bin/bjam
-
- # build bcp
- cd "${srcdir}/boost_${_boostver}/tools/bcp"
- ../build/v2/engine/${_bindir}/bjam --toolset=gcc
- install -m755 "${srcdir}/boost_${_boostver}/dist/bin/bcp" \
- ${_stagedir}/usr/bin/bcp
-
- # build libs
- cd "${srcdir}/boost_${_boostver}"
-
- # default "minimal" install: "release link=shared,static
- # runtime-link=shared threading=single,multi"
- # --layout=tagged will add the "-mt" suffix for multithreaded libraries
- # and installs includes in /usr/include/boost.
- # --layout=system no longer adds the -mt suffix for multi-threaded libs.
- # install to ${_stagedir} in preparation for split packaging
-
- ./tools/build/v2/engine/${_bindir}/bjam \
- release debug-symbols=off threading=multi \
- runtime-link=shared link=shared,static \
- cflags=-fno-strict-aliasing \
- toolset=gcc \
- address-model=32 \
- --without-python \
- --without-mpi \
- --prefix="${_stagedir}" \
- -sTOOLS=gcc \
- --layout=system \
- ${MAKEFLAGS} \
- install
+ export CC="gcc"
+ export CFLAGS="-m32"
+ export CXX="g++"
+ export CXXFLAGS="-m32"
+ export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+
+ # set python path for bjam
+ cd "${srcdir}/boost_${_boostver}/tools"
+ # echo "using python : 2.7 : /usr/bin/python2 ;" >> build/v2/user-config.jam
+ # echo "using python : 3.2 : /usr/bin/python3.2 : /usr/include/python3.2mu :
+ # /usr/lib32 ;" >> build/v2/user-config.jam
+ # echo "using mpi ;" >> build/v2/user-config.jam
+
+ # build bjam
+ cd "${srcdir}/boost_${_boostver}/tools/build/v2/engine"
+ ./build.sh cc
+
+ _bindir="bin.linuxx86"
+ _stagedir="${srcdir}/stagedir"
+
+ install -d "${_stagedir}"/usr/bin
+ install ${_bindir}/bjam "${_stagedir}"/usr/bin/bjam
+
+ # build bcp
+ cd "${srcdir}/boost_${_boostver}/tools/bcp"
+ ../build/v2/engine/${_bindir}/bjam --toolset=gcc
+ install -m755 "${srcdir}/boost_${_boostver}/dist/bin/bcp" \
+ ${_stagedir}/usr/bin/bcp
+
+ # build libs
+ cd "${srcdir}/boost_${_boostver}"
+
+ # default "minimal" install: "release link=shared,static
+ # runtime-link=shared threading=single,multi"
+ # --layout=tagged will add the "-mt" suffix for multithreaded libraries
+ # and installs includes in /usr/include/boost.
+ # --layout=system no longer adds the -mt suffix for multi-threaded libs.
+ # install to ${_stagedir} in preparation for split packaging
+
+ ./tools/build/v2/engine/${_bindir}/bjam \
+ release debug-symbols=off threading=multi \
+ runtime-link=shared link=shared,static \
+ cflags=-fno-strict-aliasing \
+ toolset=gcc \
+ address-model=32 \
+ --without-python \
+ --without-mpi \
+ --prefix="${_stagedir}" \
+ -sTOOLS=gcc \
+ --layout=system \
+ ${MAKEFLAGS} \
+ install
}
package()
{
+ _stagedir="${srcdir}/stagedir"
+
install -d "${pkgdir}/usr/lib32"
- #shared libs
- cp -r "${_stagedir}"/lib/*.so{,.*} "${pkgdir}/usr/lib32/"
-
- # license
- install -D -m644 "${srcdir}/boost_${_boostver}/LICENSE_1_0.txt" \
- "${pkgdir}"/usr/share/licenses/lib32-boost-libs/LICENSE_1_0.txt
+ #shared libs
+ cp -r "${_stagedir}"/lib/*.so{,.*} "${pkgdir}/usr/lib32/"
+
+ # license
+ install -D -m644 "${srcdir}/boost_${_boostver}/LICENSE_1_0.txt" \
+ "${pkgdir}"/usr/share/licenses/lib32-boost-libs/LICENSE_1_0.txt
}