summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Was2013-11-24 00:39:10 +0000
committerKyle Keen2013-11-24 00:39:10 +0000
commit3c5fd290653e67cf13ceb6f001015dbd4c13ae35 (patch)
tree10c302e19be685a716858c7258635e0f8e4e9107
parent00af6c0b750e4b51217f2d6dbc0c362ec59f79cb (diff)
downloadaur-3c5fd290653e67cf13ceb6f001015dbd4c13ae35.tar.gz
updated on Sun Nov 24 00:39:09 UTC 2013
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD18
-rw-r--r--boost-1.54.0-Fix-macro-for-int128-detection.patch35
-rw-r--r--fix-new-glibc.patch14
4 files changed, 10 insertions, 69 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 053805614d27..058e52cc6729 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lib32-boost-libs
pkgdesc = Free peer-reviewed portable C++ source libraries - Runtime (32 bit)
- pkgver = 1.54.0
- pkgrel = 2
+ pkgver = 1.55.0
+ pkgrel = 1
url = http://www.boost.org
arch = x86_64
groups = lib32
@@ -16,12 +16,8 @@ pkgbase = lib32-boost-libs
depends = lib32-zlib
depends = lib32-icu
depends = lib32-gcc-libs
- source = http://downloads.sourceforge.net/sourceforge/boost/boost_1_54_0.tar.gz
- source = boost-1.54.0-Fix-macro-for-int128-detection.patch
- source = fix-new-glibc.patch
- sha1sums = 069501636097d3f40ddfd996d29748bb23591c53
- sha1sums = bf5177694ab8a0df6bc13aa47b05727c40febebb
- sha1sums = e3a5fac340c12b39add50070efb439b857108a0b
+ source = http://downloads.sourceforge.net/sourceforge/boost/boost_1_55_0.tar.gz
+ sha1sums = 61ed0e57d3c7c8985805bb0682de3f4c65f4b6e5
pkgname = lib32-boost-libs
diff --git a/PKGBUILD b/PKGBUILD
index 16def6022c5a..3e4956eaaaa0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@
# Contributor : andy123 < ajs AT online DOT de >
pkgname=lib32-boost-libs
-pkgver=1.54.0
+pkgver=1.55.0
_boostver=${pkgver//./_}
-pkgrel=2
+pkgrel=1
url="http://www.boost.org"
arch=('x86_64')
pkgdesc="Free peer-reviewed portable C++ source libraries - Runtime (32 bit)"
@@ -13,12 +13,8 @@ license=('custom')
groups=('lib32')
depends=('lib32-bzip2' 'lib32-zlib' 'lib32-icu' 'lib32-gcc-libs')
makedepends=('lib32-icu>=51.1' 'lib32-bzip2' 'lib32-zlib' 'gcc-multilib' 'python' 'python2')
-source=(http://downloads.sourceforge.net/sourceforge/boost/boost_${_boostver}.tar.gz
- boost-1.54.0-Fix-macro-for-int128-detection.patch
- fix-new-glibc.patch)
-sha1sums=('069501636097d3f40ddfd996d29748bb23591c53'
- 'bf5177694ab8a0df6bc13aa47b05727c40febebb'
- 'e3a5fac340c12b39add50070efb439b857108a0b')
+source=(http://downloads.sourceforge.net/sourceforge/boost/boost_${_boostver}.tar.gz)
+sha1sums=('61ed0e57d3c7c8985805bb0682de3f4c65f4b6e5')
@@ -35,9 +31,6 @@ build() {
cd "${srcdir}/boost_${_boostver}"
- patch -Np2 -i ../boost-1.54.0-Fix-macro-for-int128-detection.patch
- patch -Np2 -i ../fix-new-glibc.patch
-
# Shut up strict aliasing warnings
echo "using gcc : : : <compileflags>-fno-strict-aliasing ;" >> ./tools/build/v2/user-config.jam
# Add an extra python version. This does not replace anything and python 2.x need to be the default.
@@ -56,9 +49,10 @@ build() {
install "${srcdir}"/boost_${_boostver}/tools/build/v2/engine/${_bindir}/bjam "${_stagedir}"/bin/bjam
pushd tools
- for _tool in bcp inspect quickbook compiler_status process_jam_log wave; do
+ for _tool in bcp inspect quickbook process_jam_log wave; do
"${_stagedir}"/bin/bjam --toolset=gcc $_tool
done
+ "${_stagedir}"/bin/bjam --toolset=gcc cflags="-std=gnu++11" compiler_status
"${_stagedir}"/bin/bjam --toolset=gcc cflags="-std=gnu++11" library_status
popd
cp -a dist/bin/* "${_stagedir}"/bin
diff --git a/boost-1.54.0-Fix-macro-for-int128-detection.patch b/boost-1.54.0-Fix-macro-for-int128-detection.patch
deleted file mode 100644
index 1f337bedfa20..000000000000
--- a/boost-1.54.0-Fix-macro-for-int128-detection.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-Index: /trunk/boost/lexical_cast.hpp
-===================================================================
---- /trunk/boost/lexical_cast.hpp (revision 84136)
-+++ /trunk/boost/lexical_cast.hpp (revision 84965)
-@@ -70,8 +70,8 @@
- #endif
-
--#if (defined(BOOST_LCAST_HAS_INT128) && !defined(__GNUC__)) || GCC_VERSION > 40700
-+// GCC 4.6 has some issues with int128 and uint128. Issues were fixed in GCC 4.7
-+#if defined(BOOST_HAS_INT128) && (!defined(__GNUC__) || __GNUC__ > 4 || (__GNUC__ == 4 && __GNUC_MINOR__ > 6))
- #define BOOST_LCAST_HAS_INT128
- #endif
--
-
- namespace boost
-Index: /trunk/libs/conversion/test/lexical_cast_integral_types_test.cpp
-===================================================================
---- /trunk/libs/conversion/test/lexical_cast_integral_types_test.cpp (revision 83717)
-+++ /trunk/libs/conversion/test/lexical_cast_integral_types_test.cpp (revision 84965)
-@@ -49,5 +49,5 @@
- #endif
-
--#if (defined(BOOST_LCAST_HAS_INT128) && !defined(__GNUC__)) || GCC_VERSION > 40700
-+#if defined(BOOST_HAS_INT128) && (!defined(__GNUC__) || __GNUC__ > 4 || (__GNUC__ == 4 && __GNUC_MINOR__ > 6))
- #define BOOST_LCAST_HAS_INT128
- #endif
-@@ -445,6 +445,6 @@
-
- // Overflow test case from David W. Birdsall
-- std::string must_owerflow_str = "160000000000000000000";
-- std::string must_owerflow_negative_str = "-160000000000000000000";
-+ std::string must_owerflow_str = (sizeof(T) < 16 ? "160000000000000000000" : "1600000000000000000000000000000000000000");
-+ std::string must_owerflow_negative_str = (sizeof(T) < 16 ? "-160000000000000000000" : "-1600000000000000000000000000000000000000");
- for (int i = 0; i < 15; ++i) {
- BOOST_CHECK_THROW(lexical_cast<T>(must_owerflow_str), bad_lexical_cast);
diff --git a/fix-new-glibc.patch b/fix-new-glibc.patch
deleted file mode 100644
index 5daa11cf5a33..000000000000
--- a/fix-new-glibc.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Index: /trunk/boost/cstdint.hpp
-===================================================================
---- /trunk/boost/cstdint.hpp (revision 84805)
-+++ /trunk/boost/cstdint.hpp (revision 84950)
-@@ -42,5 +42,8 @@
- // See https://svn.boost.org/trac/boost/ticket/3548 and http://sources.redhat.com/bugzilla/show_bug.cgi?id=10990
- //
--#if defined(BOOST_HAS_STDINT_H) && (!defined(__GLIBC__) || defined(__GLIBC_HAVE_LONG_LONG))
-+#if defined(BOOST_HAS_STDINT_H) \
-+ && (!defined(__GLIBC__) \
-+ || defined(__GLIBC_HAVE_LONG_LONG) \
-+ || (defined(__GLIBC__) && ((__GLIBC__ > 2) || ((__GLIBC__ == 2) && (__GLIBC_MINOR__ >= 17)))))
-
- // The following #include is an implementation artifact; not part of interface.