summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Was2014-09-09 00:00:23 +0000
committerKyle Keen2014-09-09 00:00:23 +0000
commit9b47b46363399746adf1b0093501c92fd322451a (patch)
tree85a8fc425f835e0d4b769bf5d07757710d86fafd
parent3c5fd290653e67cf13ceb6f001015dbd4c13ae35 (diff)
downloadaur-9b47b46363399746adf1b0093501c92fd322451a.tar.gz
updated on Tue Sep 9 00:00:22 UTC 2014
-rw-r--r--.AURINFO22
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD41
3 files changed, 39 insertions, 30 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..ecd57763b875
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,22 @@
+pkgbase = lib32-boost-libs
+ pkgdesc = Free peer-reviewed portable C++ source libraries - Runtime (32 bit)
+ pkgver = 1.56.0
+ pkgrel = 1
+ url = http://www.boost.org
+ arch = x86_64
+ groups = lib32
+ license = custom
+ makedepends = lib32-icu>=51.1
+ makedepends = lib32-bzip2
+ makedepends = lib32-zlib
+ makedepends = gcc-multilib
+ makedepends = python
+ makedepends = python2
+ depends = lib32-bzip2
+ depends = lib32-zlib
+ depends = lib32-icu
+ depends = lib32-gcc-libs
+ source = http://downloads.sourceforge.net/sourceforge/boost/boost_1_56_0.tar.gz
+
+pkgname = lib32-boost-libs
+
diff --git a/.SRCINFO b/.SRCINFO
index 058e52cc6729..6b717657dc11 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lib32-boost-libs
pkgdesc = Free peer-reviewed portable C++ source libraries - Runtime (32 bit)
- pkgver = 1.55.0
+ pkgver = 1.56.0
pkgrel = 1
url = http://www.boost.org
arch = x86_64
@@ -16,8 +16,8 @@ pkgbase = lib32-boost-libs
depends = lib32-zlib
depends = lib32-icu
depends = lib32-gcc-libs
- source = http://downloads.sourceforge.net/sourceforge/boost/boost_1_55_0.tar.gz
- sha1sums = 61ed0e57d3c7c8985805bb0682de3f4c65f4b6e5
+ source = http://downloads.sourceforge.net/sourceforge/boost/boost_1_56_0.tar.gz
+ sha1sums = 1639723c6bdff873cdb6d747f8f8c9d9f066434d
pkgname = lib32-boost-libs
diff --git a/PKGBUILD b/PKGBUILD
index 3e4956eaaaa0..6aebfb7cc629 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor : andy123 < ajs AT online DOT de >
pkgname=lib32-boost-libs
-pkgver=1.55.0
+pkgver=1.56.0
_boostver=${pkgver//./_}
pkgrel=1
url="http://www.boost.org"
@@ -14,7 +14,7 @@ groups=('lib32')
depends=('lib32-bzip2' 'lib32-zlib' 'lib32-icu' 'lib32-gcc-libs')
makedepends=('lib32-icu>=51.1' 'lib32-bzip2' 'lib32-zlib' 'gcc-multilib' 'python' 'python2')
source=(http://downloads.sourceforge.net/sourceforge/boost/boost_${_boostver}.tar.gz)
-sha1sums=('61ed0e57d3c7c8985805bb0682de3f4c65f4b6e5')
+sha1sums=('1639723c6bdff873cdb6d747f8f8c9d9f066434d')
@@ -31,33 +31,19 @@ build() {
cd "${srcdir}/boost_${_boostver}"
- # Shut up strict aliasing warnings
- echo "using gcc : : : <compileflags>-fno-strict-aliasing ;" >> ./tools/build/v2/user-config.jam
- # Add an extra python version. This does not replace anything and python 2.x need to be the default.
- #echo "using python : 3.3 : /usr/bin/python3 : /usr/include/python3.3m : /usr/lib ;" >> ./tools/build/v2/user-config.jam
- # Support for OpenMPI
- #echo "using mpi ;" >> ./tools/build/v2/user-config.jam
-
- ./bootstrap.sh --with-toolset=cc --with-icu --with-python=
+ ./bootstrap.sh --with-toolset=gcc --with-icu --with-python=
# --with-python=/usr/bin/python2
- sed -i 's/cc/gcc/g' project-config.jam
+ _bindir="bin.linuxx86_64"
+ install -Dm755 tools/build/src/engine/$_bindir/b2 "${_stagedir}"/bin/b2
- _bindir="bin.linuxx86"
-
- install -d -m 755 "${_stagedir}"/bin
- install "${srcdir}"/boost_${_boostver}/tools/build/v2/engine/${_bindir}/bjam "${_stagedir}"/bin/bjam
+ # Add an extra python version. This does not replace anything and python 2.x need to be the default.
+ #echo "using python : 3.4 : /usr/bin/python3 : /usr/include/python3.4m : /usr/lib ;" >> project-config.jam
- pushd tools
- for _tool in bcp inspect quickbook process_jam_log wave; do
- "${_stagedir}"/bin/bjam --toolset=gcc $_tool
- done
- "${_stagedir}"/bin/bjam --toolset=gcc cflags="-std=gnu++11" compiler_status
- "${_stagedir}"/bin/bjam --toolset=gcc cflags="-std=gnu++11" library_status
- popd
- cp -a dist/bin/* "${_stagedir}"/bin
+ # Support for OpenMPI
+ #echo "using mpi ;" >> project-config.jam
- #boostbook is needed by quickbook
+ # boostbook is needed by quickbook
install -d -m 755 "${_stagedir}"/share/boostbook
cp -a tools/boostbook/{xsl,dtd} "${_stagedir}"/share/boostbook/
@@ -67,22 +53,23 @@ build() {
# and installs includes in /usr/include/boost.
# --layout=system no longer adds the -mt suffix for multi-threaded libs.
# install to ${_stagedir} in preparation for split packaging
- "${_stagedir}"/bin/bjam \
+ "${_stagedir}"/bin/b2 \
variant=release \
debug-symbols=off \
threading=multi \
runtime-link=shared \
- link=shared \
+ link=shared,static \
toolset=gcc \
address-model=32 \
--without-python \
--without-mpi \
+ cflags="${CPPFLAGS} ${CFLAGS} -O3" linkflags="${LDFLAGS}" \
--layout=system \
--prefix="${_stagedir}" \
${JOBS} \
install
- find ${_stagedir} -name \*.a -exec rm -f {} \;
+ #find ${_stagedir} -name \*.a -exec rm -f {} \;
}
package() {