summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2019-08-07 23:36:32 -0400
committerVincent Grande2019-08-07 23:36:32 -0400
commit997d2dd4ec9577b8c128f078c93c5f8a5482e487 (patch)
treec84caa2cca2cdff5088d7cefe84f4cb433dccdf4
downloadaur-997d2dd4ec9577b8c128f078c93c5f8a5482e487.tar.gz
things
-rw-r--r--.SRCINFO29
-rwxr-xr-xPKGBUILD63
2 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..09f601738c00
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = lib32-colord-git
+ pkgdesc = System daemon for managing color devices
+ pkgver = 1.4.4
+ pkgrel = 1
+ url = https://www.freedesktop.org/software/colord
+ arch = x86_64
+ license = GPL2
+ makedepends = argyllcms
+ makedepends = bash-completion
+ makedepends = git
+ makedepends = gobject-introspection
+ makedepends = intltool
+ makedepends = meson
+ makedepends = python2
+ makedepends = sane
+ makedepends = vala
+ depends = colord
+ depends = lib32-dconf
+ depends = lib32-libgudev
+ depends = lib32-libgusb
+ depends = lib32-lcms2
+ depends = lib32-polkit
+ depends = lib32-sqlite
+ depends = lib32-dbus
+ source = git+https://github.com/hughsie/colord
+ sha256sums = SKIP
+
+pkgname = lib32-colord-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..3449b03c7292
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: jtts <jussaar@mbnet.fi>
+# Contributor: josephgbr <rafael.f.f1@gmail.com>
+# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
+
+pkgname=lib32-colord-git
+pkgver=1.4.4
+pkgrel=1
+pkgdesc='System daemon for managing color devices'
+arch=(x86_64)
+url=https://www.freedesktop.org/software/colord
+license=(GPL2)
+depends=(
+ colord
+ lib32-dconf
+ lib32-libgudev
+ lib32-libgusb
+ lib32-lcms2
+ lib32-polkit
+ lib32-sqlite
+ lib32-dbus
+)
+makedepends=(
+ argyllcms
+ bash-completion
+ git
+ gobject-introspection
+ intltool
+ meson
+ python2
+ sane
+ vala
+)
+source=(git+https://github.com/hughsie/colord)
+sha256sums=(SKIP)
+
+build() {
+ export CC='gcc -m32'
+ export CXX='g++ -m32'
+ export PKG_CONFIG_PATH=/usr/lib32/pkgconfig
+
+ arch-meson colord build \
+ --libdir=/usr/lib32 \
+ -D bash-completion=false \
+ -D docs=false \
+ -D man=false \
+ -D tests=false \
+ -D libcolordcompat=true \
+ -D sane=false \
+ -D vapi=true \
+ -D print-profiles=false \
+ -D daemon-user=colord
+ ninja -C build
+}
+
+package() {
+ DESTDIR="${pkgdir}" ninja -C build install
+ rm -r "${pkgdir}"/usr/{bin,include,lib,share}
+}
+
+# vim: ts=2 sw=2 et: