summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2021-01-09 22:49:09 -0500
committerVincent Grande2021-01-09 22:49:09 -0500
commitd17db0b5e0ae114a345aaae5f4be5a2c77ee310a (patch)
tree005f3d25f60bb568868b12e342bb8f2c0cdc3459
downloadaur-d17db0b5e0ae114a345aaae5f4be5a2c77ee310a.tar.gz
initial upload
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD52
2 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..153674c3a0e0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = lib32-dbus-glib-git
+ pkgdesc = GLib bindings for DBUS
+ pkgver = 0.110
+ pkgrel = 1
+ url = https://www.freedesktop.org/wiki/Software/DBusBindings
+ arch = x86_64
+ license = GPL
+ makedepends = gcc-multilib
+ makedepends = lib32-expat
+ makedepends = python
+ depends = dbus-glib
+ depends = lib32-glib2
+ depends = lib32-glibc
+ depends = lib32-dbus
+ provides = lib32-dbus-glib
+ conflicts = lib32-dbus-glib
+ options = !emptydirs
+ source = git+https://gitlab.freedesktop.org/dbus/dbus-glib.git
+ sha256sums = SKIP
+
+pkgname = lib32-dbus-glib-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a3d259b7ba2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Martin Wimpress <code@flexion.org>
+# Contributor: josephgbr <rafael.f.f1@gmail.com>
+
+pkgname=lib32-dbus-glib-git
+pkgver=0.110
+pkgrel=1
+pkgdesc='GLib bindings for DBUS'
+arch=('x86_64')
+license=('GPL')
+url='https://www.freedesktop.org/wiki/Software/DBusBindings'
+depends=('dbus-glib' 'lib32-glib2' 'lib32-glibc' 'lib32-dbus')
+makedepends=('gcc-multilib' 'lib32-expat' 'python')
+provides=(lib32-dbus-glib)
+conflicts=(lib32-dbus-glib)
+options=('!emptydirs')
+source=("git+https://gitlab.freedesktop.org/dbus/dbus-glib.git")
+#validpgpkeys=('DA98F25C0871C49A59EAFF2C4DE8FF2A63C7CC90') # Simon McVittie
+sha256sums=('SKIP')
+
+pkgver() {
+ cd dbus-glib
+ git describe --tags | sed 's/-/+/g'
+}
+
+build() {
+ cd dbus-glib
+
+ export CC='gcc -m32'
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+
+ ./configure \
+ --prefix='/usr' \
+ --libdir='/usr/lib32' \
+ --localstatedir='/var' \
+ --sysconfdir='/etc' \
+ --disable-bash-completion \
+ --disable-checks \
+ --disable-gtk-doc-html \
+ --disable-static
+ make
+}
+
+package() {
+ cd dbus-glib
+
+ make DESTDIR="${pkgdir}" install
+ rm -rf "${pkgdir}/usr"/{bin,include,share}
+}
+
+# vim: ts=2 sw=2 et: